cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6861
Views
5
Helpful
11
Replies
Highlighted
Beginner

Jabber for Windows: Name displayed as user@domain and not Lastname, Firstname

hi

we have cups 8.6.4 with cucm 8.6.2 and cisco jabber 9.1.3 clients. CUCM and CUPS are AD integrated with 2008 r2 domain.

i have noticed that some users do not have their name listed as Lastname, Firstname but as user@domain.com

i did the following test on a users desktop

1) logged in as user AB and name was displayed as AB@domain.com

2) i logged out and logged in as me and my name was displayed as Lastname, Firstname

3) i logged myself out and logged back in as user AB and now that user was also showing Lastname, Firstname

4) i closed the application and started it again, logged in as AB and now it is back as AB@domain.com

very weird

this does not happen on our mac jabber clients, only on windows and not all users but some of them (the most recent ones i have been adding to the system)

what can i check to see why this does not work and why would it show the name correctly after i log in with my details and then revert back again,  that is really strange

Everyone's tags (1)
11 REPLIES 11
Highlighted
Participant

Jabber for Windows: Name displayed as user@domain and not Lastna

In order for name at the top to change from User@domain.com, Jabber has to resolve the name somehow.

By default it tries to auto detect available LDAP/GC servers and logs into them using the windows credentials in order to do an LDAP lookup for any field matching the "user" part of user@domain.com

If it finds a record with a field that matches "user" it substitues user@domain.com for firstname and lastname from AD.

If you go to help - report a problem -> contacts list and save the file to your desktop you will be able to see in csfunified.log the process to try to match "username@domain.com" with LDAp source.

You will also see why it fails.

Try searching this file for the word "Black"

you may find your LDAP servers are being black listed.

I had a problem with Jabber 9.1.3 recently, slightly different application, but no matter what I did it would not resolve users against LDAP on a PC that wasnt inside the windows domain, even if you told it to use custom LDAP credentials.

The fix was to revert to 9.0.5.

Highlighted
Beginner

Jabber for Windows: Name displayed as user@domain and not Lastna

Hello.

This behavior points to a bad attribute mapping and/or  wrong connection to the LDAP servers. Could you please answer the  following questions in order to assist you better:

> How many LDAP servers do we have?

> Is this problem isolated to Jabber for windows?

> Is CUCM also LDAP integrated? If so what LDAP attribute is mapped to the userID?

> Are we using the jabber-config.xml file the Jabber clients?

Regards,

- Fabricio MS

Highlighted
Beginner

Jabber for Windows: Name displayed as user@domain and not Lastna

we have 2x ldap servers (windwos 2008 r2 DC) configured

no it sometimes happens on mac clients also

yes. sAMAccountName is the ldap attribute for user id

using carinewton log file (previous post) i can see that there is no jabber-config.xml file in use

i cannot find the word black in the log file

Highlighted
Participant

Jabber for Windows: Name displayed as user@domain and not Lastna

When you export the information like I said before, there should be a folder called config.

This should contain a file called Jabber-config.xml - can you post it please?

Could you also post your csfunified.log?

Be careful to remove any passwords or sensitive information

If you search the csfunified.log file for your username (The sAmaccountname or the part before the @ symbol at the top of jabber) at around the time you log in to Jabber, you should se it try to resolve your user against LDAP.  I believe this is failing and thats why its just showing email address.

Is the machine you are on a member of the windows domain?

By default I belive Jabber uses windows credentials to log in to whatever AD server it can find and try to resolve the username.

Highlighted
Beginner

Jabber for Windows: Name displayed as user@domain and not Lastna

it is a member of the domain (not standalone or work group)

i had to login as someone else on my computer (sd@domain.com) as the other csfunified.log had too much confidential informaiton in there to remove.

i am trying to figure out how to attache the log file to this post as it is too long to embed in this post itself

there is no jabber-config.xml file in the location you mentioned, the log files indicated failure to download this from the tftp server (but then again i do not remembering setting anything up when i build out the cups server.

Highlighted
Participant

Jabber for Windows: Name displayed as user@domain and not Lastna

Im not sure how to attach files either! Might be worth hosting it elsewhere and using the "insert link" button?

Highlighted
Beginner

Jabber for Windows: Name displayed as user@domain and not Lastna

Highlighted
Participant

Jabber for Windows: Name displayed as user@domain and not Lastna

I don't see the person resolver searching LDAP for your details (for the user SD@domain.com)

Is this a lab scenario? Is the domain domain.com valid?

In my deployment we were LDAP integrated and person resolution from non-domain machines wouldnt work, because jabber by default uses windows credentials to search whatever domains it can find, so for non domain machines it would fail.  We had to specify the address of the DC to use, and the crednetials to use while searching it in jabber-config.xml.  Then it started to work.

your deployment is slightly different and I dont see Jabber trying to resolve the username for the user through LDAP.  What version of Jabber is this? Are CUCM and CUPS LDAP Integrated?

I see your CUCM is 8.6, which means your presence must match.  My experience is with 9.1 so may not be applicable to your deployment I'm afraid, I have not had to troubleshoot this before on 8.6 so might be sending you up teh wrong path im afraid!

Highlighted
Beginner

Jabber for Windows: Name displayed as user@domain and not Lastna

no working environment (albeit a small one with 12 users using it and another 12 waiting deployment

domain.com is valid

cucm and cups use same ldap servers (window 2008 r2 AD)

cucm is 8.6.2 and cups is also 8.6(4 i believe)

the weird thing is that for me it logs in okay, shows initials and then full displayname within 1 second

if i log out of jabber , and login as the other user it shows initials and then full displayname

if i then exit of of jabber and log back in as the 2nd user, it shows initials and does not resolve the displayname

it never happens to me (only once in mac client)

this happens on client version 9.1.3 and 9.1.4 (i do not have older clients)

Highlighted
Participant

Re: Jabber for Windows: Name displayed as user@domain and not La

Shot in the dark but check proxyaddress ad attribute is set for users?

It's in the design guide for jabber, I don't think you can access the property using standard users and computers

Sent from Cisco Technical Support iPhone App

Highlighted
Beginner

Re: Jabber for Windows: Name displayed as user@domain and not La

yes they do have the proxyaddres ad tribute set

one thing i have noticed that some users have this in uppercase (SD@domain.com) and mine is in lowercase xxx@domain.com but it could not be that could it? and even if it is why does it work (briefly) when logging out as a working user (displayname working) and logging back in with the non working user and the displayname works for that user until you exit the jabber client