cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
14032
Views
20
Helpful
31
Replies
Jiri Solc
Contributor

Jabber ID as Directory URI fail when searching for contacts, Jabber still returns userID@domain as IM address

I've got a problem with JID set to Directory URI in CUCM/IMP 10.5. We've set up IMP node to Directory URI as IM Address Scheme in IMP Admin > Presence > Settings > Advanced Configuration. Directory URI is synced from email address in LDAP integration, every user has correct Directory URI value.

Despite this setup client (JfW 10.5) always returns userID@domain as IM address for every LDAP user I try to search. If I add user manually with JID=Directory URI address, user is identified correctly and communication is working. 

IMP Documentation says EDI must be used to get this working. UDS is not supported at this time. Unfortunatelly I can't get contact search working even with EDI and desktop in MS AD domain.

 

For example:

My JID = email = Directory URI = jiri.solc@domain.cz

My userID = solc

When I search for contacts, Jabber returns solc@domain.cz as IM address every time.

 

Only workaround is to add a contact manually without searching for one.

 

Any ideas? Thank you...

1 ACCEPTED SOLUTION

Accepted Solutions

Hello.

We were able to solve this as well. We are using UDS only.

We have the following:

CUCM 10.5.1

IM&P 10.5.1

Jabber 10.6 - We had to reset all instances of this to get the proper jabber-config.xml to download. Then remove contacts and re-add.


On our CUCM service profile for Jabber we have Directory / LDAP set to none, however, we have Use UDS checked.
 

Here is our jabber-config.xml. Also make sure your tftp is reachable, and also that you have saved the xml file in utf-8 text format.

 

<?xml version="1.0" encoding="utf-8"?>
<config version="1.0">
 <Policies>
   <EnableSIPURIDialling>false</EnableSIPURIDialling>
   <DirectoryURI>mail</DirectoryURI>
 </Policies>
 <Presence>
  <PresenceServerAddress>presence-server-address-here</PresenceServerAddress>
  <PresenceServerDomain>presence-server-domain.com-here</PresenceServerDomain>
 </Presence>
 <Directory>
   <IMAddresses use-default="false">
      <IMAddress>mail</IMAddress>
   </IMAddresses>
   <UseSIPURIToResolveContacts>true</UseSIPURIToResolveContacts>
   <SipUri>mail</SipUri>
   <DirectoryServerType>UDS</DirectoryServerType>
   <PresenceServer>presence-server-address-here</PresenceServer>
   <UdsServer>callmanager-server-address-here</UdsServer>
 </Directory>
</config>

 

View solution in original post

31 REPLIES 31
Jiri Solc
Contributor

I'm also looking forward UDS/BDI supports Directory URI or support for EDI/BDI when using MRA. :-(

Hi,

 

were you able to get it work with Directory URI?

No I wasn't. I think it's not possible with current Jabber 10.5. Directory URI is only supported when using EDI and only inside corporate network.

I'm actually looking forward this new Jabber 10.6 feature that might solve this problem with "Flexible JID Structure".

 

Hi,

If I understand the issue correctly.

  • Issue is that when you search new users in Jabber search bar, new user is added into Jabber with "Chat (IM address)" in the format of domain_user_id@domain and not in format of "Directory URI (=email)".
  • In CUCM directory synchronization, e-mail is set up such as "Directory URI" attribute
  • You have set IM Schema as "Directory URI" on IM&P.
  • You have got Jabber 10.5, CUCM 10.5 and CUCM IMP 10.5
  • You tried using EDI integration for testing.

If you are planing to test with the EDI directory integration again.

You can try the below xml tags in the jabber-config.xml file to enable Jabber client to retrieve the IM address from Mail field in Active Directory client.

<Directory>

<IMAddressesuse-default=”false”>

        <IMAddress>mail</IMAddress>

    </IMAddresses>

</Directory>

 

or

 

<Directory>

 <IMAddressesuse-default=”false”>

        <IMAddressprefix=”sip:”>msRTCSIP-PrimaryUserAddress</IMAddress>

    </IMAddresses>

</Directory

 

Regards,

Ankoor

Hi,

 

any news? I have the same problem but the xml part above doesn't resolve my problem!

 

i see always  domain_user_id@domain and not only the mail, that correspond to the URI

 

Let me know please.

 

Thanks

What I have been told about this is that in Jabber 10.6 the Jabber client will be able to support the Directory URI for search.

Anyone have 10.6 resolve this issue? I have installed it, but issue remains.

I'm having the same issue, but according to the 10.5.2 imp documentation, this is still not supported with UDS as someone else pointed out a few months ago with a previous version.

thanks,

 

I have this working in a multi-cluster/multi-forest environment..  jabber-config file is below, one thing to note as I just recently discovered, the sip: that prefixes the msRTCSIP-primaryuseraddress in ad is case sensitive, in this environment, two of the forests used lowercase sip: and the other two used uppercase SIP:.  I would get scenarios where when you perform a contact search, it would resolve the name but would not strip the prefix from the IM address.  Also the Service profile in UC has the "Use UDS for contact resolution" box checked.

 

<?xml version="1.0" encoding="utf-8"?>
<config version="1.0">
 <Options>
     <Start_Client_On_Start_OS>true</Start_Client_On_Start_OS>
     <AllowUserCustomTabs>true</AllowUserCustomTabs>
     <DockedWindowVisible>true</DockedWindowVisible>
 </Options>
 <Phone>
   <EnableDSCPPacketMarking>true</EnableDSCPPacketMarking>
 </Phone>
 <Policies>
    <enableLocalAddressBookSearch>false</enableLocalAddressBookSearch>
    <File_Transfer_Enabled>false</File_Transfer_Enabled>
    <EnableSIPURIDialling>true</EnableSIPURIDialling>
    <DirectoryURI>msRTCSIP-PrimaryUserAddress</DirectoryURI>
    <ServicesDomainSsoEmailPrompt>OFF</ServicesDomainSsoEmailPrompt>
    <disable_im_history>true</disable_im_history>
 </Policies>
 <Directory>
 <UseSIPURIToResolveContacts>true</UseSIPURIToResolveContacts>
 <UriPrefix>sip:</UriPrefix>
 <SipUri>msRTCSIP-PrimaryUserAddress</SipUri>
 <PhotoUriSubstitutionToken>sAMAccountName</PhotoUriSubstitutionToken>
 <PhotoUriWithToken>http://YOURCOMPANYWEBSERVER.COM/adphotos/%%uid%%.jpg</PhotoUriWithToken>
 <UdsPhotoUriWithToken>http://YOURCOMPANYWEBSERVER.COM/adphotos/%%uid%%.jpg</UdsPhotoUriWithToken>
 </Directory>
</config> 

The xml configurations you are referring to are supposed to be used with EDI directory integrations and not with UDS, like when you are connected via Expway. Were you able to verify your setup Flexible JID setup works with clients connected through Expway (doing things like adding new contacts)?

If I'm not mistaken, documentation for IMP 10.5.2 clearly states that URI based JID is not supported with UDS, which makes me think that multidomain environments are still not supported  with UDS integrations.

thanks!

You are correct, it is supposed to be in Beta still on the producion release of jabber 10.6, however this configuration does work when using only UDS for both on premise and off premise deployments.  The issue was still in place on the 10.5 train of jabber where it would append the incorrect domain to the IM address if you click the contact that is resolved during a predictive search while adding contacts.  

 

Unless I am mistaken, the Flexible JID feature is still in beta on 10.6, but does work with this config.

Hi, 

Looking through all this as im getting the same thing.

 

If I login as me@mydomain.com then when do a lookup for personA the chatIM address appears as personA@mydomain.com but is really personA@otherdomain.com, also appears on the presence cluster correctly. So appears it just gets the userId and adds my what ever domain my own account logged into.

 

Is there a clear fix on this as appears to be different sources stating different things? Running recent presence 10.5x and getting customer to update the Jabber 10.6 client to full release as was running beta.

 

Brian, i am interested what directory your jabber client connects to EDI or UDS?

I am having to force UDS for both on site and mobile access.  Also in this scenario I had to sync all four AD forests to All four UC clusters...  1 of the forest on each cluster sets the User for home cluster, the other 3 I just apply a feature group template that does not enable any services, nor does it set the home cluster option.  Supposedly if you have a single AD forest with multiple subdomains, EDI or BDI is supported for Flexible JID.  I am running 10.5.2 im&p and 10.6 on jabber.  One side not on this one though, I am having to fight with presence issues being shared between exchange, etc..  so it is not the ideal way to implement this solution, but the name resolution portion will work as advertised.

Using:

   <IMAddresses use-default="false">
      <IMAddress>mail</IMAddress>
   </IMAddresses>
is unsupported. If you are using this configuration you are in an unsupported configuration and will not be supported by Cisco.
The only correct config is:
<Directory>
  <SipUri>mail</SipUri>
  <UseSIPURIToResolveContacts>true</UseSIPURIToResolveContacts>

  <BDISipUri>mail</BDISipUri>
  <BDISipUriToResolveContacts>true</BDISipUriToResolveContacts>
</Directory>
Content for Community-Ad

Spotlight Awards 2021