cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
61398
Views
15
Helpful
19
Replies
dcklein01
Beginner

Webex Mapi Component login prompt

Our users are randomly getting a popup for the Webex Mapi Component. It will only accept their username in the form of username@domain.local and no other. I know that Jabber is causing the popup since it's the only program starting. And if I close Jabber, the popup goes away. The issue occurs randomly for different users at different times, usually when Jabber starts though. How can we get rid of this login prompt?

All our users are running Windows 7 or 10 with Jabber 11.6 or newer.

19 REPLIES 19
Varundeep Chhatwal
Cisco Employee

Hello

This is related to the integration of your jabber with Outlook. If you can share the screenshot of error , i can see further to this. Could you please confirm if jabber and outlook were installed by admin rights ?

Also please confirm if you receive this message during the login process or during jabber session.

also please share the version of Outlook as well

We are using Outlook 2010.

Can you please check the below

Step 1

Open the email account settings in Microsoft Outlook, as in the following example:

  1.  Select File > Account Settings.
  2.  Select the Email tab on the Account Settings window.

Step 2

Double-click the server name.
In most cases, the server name is Microsoft Exchange.

Step 3
Select the Use Cached Exchange Mode checkbox.

Step 4
Apply the setting and then restart Microsoft Outlook

Also , if possible can you ad the below parameters in jabber-config xml file and then check if issue is there or not.


<Directory>
<UseWindowsCredentials>0</UseWindowsCredentials>

</Directory>

<Policies>
<enableLocalAddressBookSearch>false</enableLocalAddressBookSearch>
</Policies>

If this also don't resolves the issue then looking into PRT could tell us something.

Can you tell me what these options will do? I'm having trouble finding information on them.

UseWindowsCredentials , this parameter will disallow the jabber not use windows credentials and enableLocalAddressBookSearch  will disallow jabber to search users from outlook.

Hi Team we too having the same issue here at MAZDA Australia, could you kindly help us resolve this issue please?

Thanks

After I deleted my cached Windows credentials for MS Office and restarting my PC, the issue went away. I cleared them in control panel on my Windows 10 Pro here:

Control Panel\All Control Panel Items\Credential Manager

Hi, Rob.
Your hint helped me for Win7.

Hi Mate
Jabber is in fact behaving correctly and the reason the MAPI pop up was being received in our case was that Jabber could not access the exchange server which it needs to pull contacts. ( users were logging into jabber via MRA at home and jabber could not connect to the exchange server as it was looking for a local address.

Problem Description:
======================
customer when connecting via MRA gets prompted with a mapi connection to connect to exchange once jabber is launched he does not get this same prompt when logging on internal network
 
 
Action Taken:
==================
Requested customer to get the following information
 
1)Go to the jabber client
File-reset jabber (this will clear the cache)
2)Now login to jabber over the VPN and when it pops up with the message take a print screen of the message
3)Collect a problem report 
--from the Problem report from the client we can see that the user is connected over MRA
 
So what is happening is that when users go home because you have the auto login enabled on start up on the PC, jabber launches itself and connects over MRA and when connected over MRA jabber needs access to the exchange for getting information about calendaring and contact search so it tries to contact to outlook and hence prompts the user to login
So to prove this, disable jabber to start up on windows boot up, so users can go home and start up their PC and connect to the VPN and then launch jabber as they are on the domain the outlook connection to exchange is already  there and jabber will not prompt you for the logon same as you see when you are internally.
 
The very short answer, Jabber is working as designed and the only way to prevent the pop up is to completely disable the Exchange integration, which you probably do not want to do.
 
This document is a reference for MAPI, which is how Jabber connects to Exchange.  Cisco has no control over the behavior of this API, because is Microsoft's code.
https://msdn.microsoft.com/en-us/library/windows/desktop/dd296726%28v=vs.85%29.aspx
 
Basically the pop-up behavior is controlled by MAPI interface MAPILogon. Based on what we were told from Microsoft about how the MAPILogin function works, it will prompt for password if the network environment changes. This symptom matches what is see in your environment. The likelihood of Microsoft changing the function to not prompt on network address change is extremely unlikely.
 
The workaround I would suggest:
===============================
a)Disable Jabber to start on PC boot up and so user have to manually bring up jabber
b)when user go home they need to exit and log out of jabber
c)when they first go home they need to bring up their VPN first and then launch jabber so they will not be prompted
 
 

mbstrauss,

Were you all able to resolve this issue?  If so, what was your solution or workaround?  My organization is still experiencing the same thing however, we are all on Office 2013 with Exchange 2010 moving to 2013.  

Thanks,

Nick

Hey nicholashinojosa,

We were able to resolved the issue. We were able to check the "Remember my credentials" when prompted by Outlook. The next time we sign in to Jabber no more prompt. 

This will occur when offline and Jabber launches prior to authentication to the company network directly or through VPN.  Is there a way to disable the prompt from popping up but leaving Jabber settings the same so that integration with Outlook calendar remains.  The only way I found to disable this is by removing Jabber from startup or removing Calendar integration in Jabber settings. 

We have the same issue in our company. Would it be possible to get rid of the "WebEX mapi component" PopUp and still use the local address book search for Jabber?

Any help is appreciated!

Create
Recognize Your Peers
Content for Community-Ad