cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

A question about the query syntax

93
Views
0
Helpful
0
Comments

Subject: RE: New Message from Natan Sanson in Cisco Unity Connection Provisioning In
Replied by: Natan Sanson on 30-04-2010 07:55:15 AM
Hi David, our version is 7.1.3.10000-68. Which version shoud we upgrade to avoid this bug?


Thanks in advance. I'm looking forward for a response.


Natan
This document was generated from CDN thread

Created by: Natan Sanson on 29-04-2010 09:20:23 AM
Hi, I'm trying to do the provisioning of users and password inside a Cisco Unity Connection but I'm facing some issues. Using a query like this one
 
https://myhostname/vmrest/users?query=(alias is username)
 
it works as expected returning me all user data.
When I try to query my users, they have an alias composed by "name surname".
 
Trying to make a query like
 
https://myhostname/vmrest/users?query=(alias is name surname)
 
CISCO Unity connection answer with an error:
 
<ErrorDetails>
<errors>
<code>INVALID_PARAMETER</code>
<message>
filter should have three parts: alias is name surname, type=3
</message>
</errors>
</ErrorDetails>
 
How can I pass "name surname" as a unique parameter? I've tried a lot of escaping caracters, to use %20 instead of space. Nothing seems to work.
 
Any help is appreciated.
 
Thank you
 
   Natan
 
 

Subject: RE: New Message from Natan Sanson in Cisco Unity Connection Provisioning In
Replied by: David Wanagel on 29-04-2010 10:02:35 AM
This is a defect that was found and fixed in the main code branch.  What version of Connection are you running?



-Dave



From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
Sent: Thursday, April 29, 2010 5:20 AM
To: cdicuser@developer.cisco.com
Subject: New Message from Natan Sanson in Cisco Unity Connection Provisioning Interface (CUPI) - CUPI Questions: A question about the query syntax



Natan Sanson has created a new message in the forum "CUPI Questions":
--------------------------------------------------------------
Hi, I'm trying to do the provisioning of users and password inside a Cisco Unity Connection but I'm facing some issues. Using a query like this one

https://myhostname/vmrest/users?query=(alias is username)

it works as expected returning me all user data.
When I try to query my users, they have an alias composed by "name surname".

Trying to make a query like

https://myhostname/vmrest/users?query=(alias is name surname)

CISCO Unity connection answer with an error:

<ErrorDetails>
<errors>
<code>INVALID_PARAMETER</code>
<message>
filter should have three parts: alias is name surname, type=3
</message>
</errors>
</ErrorDetails>

How can I pass "name surname" as a unique parameter? I've tried a lot of escaping caracters, to use %20 instead of space. Nothing seems to work.

Any help is appreciated.

Thank you

   Natan


--
To respond to this post, please click the following link:
<http://developer.cisco.com/web/cupi/forums/-/message_boards/message/2156523>
or simply reply to this email.

Subject: RE: New Message from Natan Sanson in Cisco Unity Connection Provisioning In
Replied by: David Wanagel on 30-04-2010 09:59:35 AM
The defect is fixed in a  code branch that has not yet been released, we will have to investigate the possibility of porting the fix into the 7.1.3ES branch.



-Dave



From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
Sent: Friday, April 30, 2010 3:55 AM
To: cdicuser@developer.cisco.com
Subject: New Message from Natan Sanson in Cisco Unity Connection Provisioning Interface (CUPI) - CUPI Questions: RE: New Message from Natan Sanson in Cisco Unity Connection Provisioning In



Natan Sanson has created a new message in the forum "CUPI Questions":
--------------------------------------------------------------
Hi Dave, our version is 7.1.3.10000-68. Which version shoud we upgrade to avoid this bug?


Thanks in advance. I'm looking forward for a response.


Natan
--
To respond to this post, please click the following link:
<http://developer.cisco.com/web/cupi/forums/-/message_boards/message/2155635>
or simply reply to this email.

Subject: RE: New Message from Natan Sanson in Cisco Unity Connection Provisioning In
Replied by: David Wanagel on 03-05-2010 11:29:35 AM
Not in any existing version of 7.1.5, that will also need a port into the ES branch.



-Dave



From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
Sent: Monday, May 03, 2010 3:39 AM
To: cdicuser@developer.cisco.com
Subject: New Message from Natan Sanson in Cisco Unity Connection Provisioning Interface (CUPI) - CUPI Questions: RE: New Message from Natan Sanson in Cisco Unity Connection Provisioning In



Natan Sanson has created a new message in the forum "CUPI Questions":
--------------------------------------------------------------
Dave, if we do an upgrade  to 7.1.5 does it work?

Thank you,

   Natan
--
To respond to this post, please click the following link:
<http://developer.cisco.com/web/cupi/forums/-/message_boards/message/2160806>
or simply reply to this email.

Subject: RE: New Message from Natan Sanson in Cisco Unity Connection Provisioning In
Replied by: Natan Sanson on 03-05-2010 07:39:11 AM
Dave, if we do an upgrade  to 7.1.5 does it work?
 
Thank you,
 
   Natan

Subject: RE: New Message from Natan Sanson in Cisco Unity Connection Provisioning In
Replied by: PATRICK NOWICKI on 25-10-2010 10:18:12 PM
Hi David,
Could you tell me if this is fixed in 8.0? and if so, what release?
 
thank you!

Subject: RE: New Message from Natan Sanson in Cisco Unity Connection Provisioning In
Replied by: David Wanagel on 26-10-2010 10:29:35 AM
It appears that this fix was ported to 7.1.3ES37, 7.1.5ES10, 8.0.2ES9 and 8.0.3, 
 
-Dave
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here