cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Call disconnect on Call Answer

1736
Views
0
Helpful
0
Comments
This document was generated from CDN thread

Created by: Christoph Mueller on 14-11-2013 10:56:05 AM
Hello,

from one minute to the other, we cannot answer incoming calls on CTI Ports via TAPI anymore.
Call.Accept works fine, but the second we Answer the call on the CTI Port, the call goes to state disconnected.

This used to work just fine, but suddenly stopped working.

Does anyone have an idea what the problem could be?

Subject: RE: Call disconnect on Call Answer
Replied by: Dustin Armstrong on 14-11-2013 10:59:26 AM
Christoph,
Is the endpoint a SIP endpoint? If so, perhaps the problem is related to the codec.

Subject: RE: Call disconnect on Call Answer
Replied by: David Staudt on 14-11-2013 11:36:54 AM
The symptom does sound typical of situations where media setup for the call fails for some reason.  This could be due to:
- CTI port codec mismatch with the phone (e.g. due to Region codec restrictions)
- Codec mismatch not able to resolved by inserting a media transcoding point (MTP), either due to no transcoding resources available, or all resources busy
- Phone security configuration requires secure signaling/media (not supported by CTI ports)
- Invalid media registration values given for the CTI port, e.g. IP address specified as '0.0.0.0' (static registration)
- Invalid media values returned to Open Logical Channel events (dynamic registration)
If you are unable to determine the cause of the media setup failure, it may be necessary to examine the UCM system log or Callmanager service logs for the exact reason.  It would be best to open a CDN Developer Support case for this level of troubleshooting: http://developer.cisco.com/web/join-the-network/support-only

Subject: RE: Call disconnect on Call Answer
Replied by: Christoph Mueller on 15-11-2013 05:31:39 AM
The strange thing is, that everything worked fine until yesterday. Our IT department, that is responsible for the CUCM, says that they didn't change anything.
I tried different TAPI Test Utilities on our CTI Ports and everytime I answer a call, it immediately gets disconnected.
This is what the TSP Log says:

12:15:22.185 |   CSelsiusTSPLine::CallStateChangedEvent() LineId:[0x0000A0CE] CallStateEvent for call=0x63db3f0, state=14, stateChangeCause=47, callReason=1,remoteInUse=0, callSelectStatus=0, callPrivacyStatus=0, IsConsultCallRollOver = 0

What is stateChangeCause 47?

Subject: RE: Call disconnect on Call Answer
Replied by: David Staudt on 15-11-2013 10:38:22 AM
I believe that is an internal cause code: CAUSE_RESOURCESNAVAIL
Which would tend to reinforce suspicion that some sort of codec/transcoder/MTP/region issue (or other media-setup problem) is occurring. 
As the ability of TAPI is pretty limited to describe exactly what the error might be in a complex network like UCM, we would probably need to look at the CTI Manager/Callmanager logs (in a addition to a full set of TSP logs) in detail to ascertain the precise cause.
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards