cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

GetSite : Response Validation Error

778
Views
0
Helpful
1
Comments
This document was generated from CDN thread

Created by: Prabodh Panda on 15-05-2013 05:00:13 AM
Hi,
When i make a GetSite request 
 
<?xml version="1.0" encoding="ISO-8859-1"?>
<serv:message xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<header>
<securityContext>
<webExID>hostid</webExID>
<password>hostpassword</password>
<siteID>0000</siteID>
<partnerID>9999</partnerID>
<email>johnsmith@xyz.com</email>
</securityContext>
</header>
<body>
<bodyContent xsi:type="java:com.webex.service.binding.site.GetSite" />
<returnSettings>
<eventCenter>true</eventCenter>
</returnSetting>
</body>
</serv:message>
 
i always get a reponse "validation: unable to find FieldDescriptor for 'returnSettings' in ClassDescriptor of body"
<?xml version="1.0" encoding="UTF-8"?>
<serv:message xmlns:serv="http://www.webex.com/schemas/2002/06/service" xmlns:com="http://www.webex.com/schemas/2002/06/common"><serv:header><serv:response><serv:result>FAILURE</serv:result><serv:reason>validation: unable to find FieldDescriptor for 'returnSettings' in ClassDescriptor of body</serv:reason><serv:gsbStatus>PRIMARY</serv:gsbStatus><serv:exceptionID>999999</serv:exceptionID></serv:response></serv:header><serv:body><serv:bodyContent/></serv:body></serv:message>
Please can anyone help on this ?
Plus I see mismatch in the request string tagname for the element ID "returnSettings", please correct on this.
 
Thanks & Regards,
Prabodh 
 
 

Subject: RE: GetSite : Response Validation Error
Replied by: Nathan Morrow on 15-05-2013 12:11:42 PM
Hello,
 
     The error suggests that you are setting returnSettings as a child of body when it should be a child of bodyContent. I was able to test this request with returnSettings successfully. The reference guide is fairly old and will be updated, spelling errors, including returnSetting, should be addressed before a new guide is released.
 
<?xml version="1.0" encoding="UTF-8"?>
<serv:message xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <header>
    <securityContext>
      <webExID>removed</webExID>
      <password>removed</password>
      <siteID>removed</siteID>
      <partnerID>removed</partnerID>
     </securityContext>
  </header>
  <body>
    <bodyContent xsi:type="java:com.webex.service.binding.site.GetSite">
      <returnSettings>
        <eventCenter>TRUE</eventCenter>
      </returnSettings>
    </bodyContent>
  </body>
</serv:message>

Subject: RE: GetSite : Response Validation Error
Replied by: Prabodh Panda on 16-05-2013 08:22:33 AM
Hi Nathan,
Thanks! for the Reply
I did try as suggested to access the GetSitr API, but i am getting response in Junk Values like below 
"?c???????????????????????????????????????????????????????????????????????????????????" 
I am able to succesfully get response from API GetUser, CreateMeeting, GethosturlMeeting and LstsummaryMeeting API from my C++ aplication. I am not able to get API GetSite and lstTimeZone working.
I am currently using "xml_api_5 9.pdf" document as my reference, please update me if this is not the latest document.
Thanks & Regards,
Prabodh 
 

Subject: RE: GetSite : Response Validation Error
Replied by: Nathan Morrow on 16-05-2013 11:37:37 AM
On the code samples page of this portal, there is a link on the right side of the page to an XML debug html file that allows you to submit a raw XML request and see the response. The response you are getting appears to be an issue with how your code handles the character encoding or some other code issue.
Comments
Advisor

Change this from <bodyContent xsi:type="java:com.webex.service.binding.site.GetSite" /> to

<bodyContent xsi:type="java:com.webex.service.binding.site.GetSite" >  

<returnSettings>

<eventCenter>true</eventCenter>

</returnSettings>

</bodyContent>

Content for Community-Ad