cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

ICM Label Transfer Timeout

721
Views
0
Helpful
1
Comments
This document was generated from CDN thread

Created by: Bill Westby on 13-09-2010 05:07:09 PM
We use CVP Type 10 VRUs and I'm trying to call an ICM script and do a label transfer to an external number. 
 
The ICM Script is very simple:
1) Prompt for digit entry "1"
2) If agent presses "1" perform a "LABEL" "transfer" to "106" plus 10 digit PSTN number
3) I have a static route on the CVP Call Server SIP tab to route "106>" to my CUCM (Call Manager)
4) I have a translation route in CUCM to strip the 106 off and insert a "91" which dials out my PRI
 
I'm testing this by calling my cell phone.  My cell phone does ring and if I answer all works fine.
 
If I do not answer my cell phone, my Cisco phone disconnects after 18 seconds exactly, I've traced this in the CTI logs but only see Normal Call Clearing.  This causes me to believe that CVP is doing a "warm" transfer of sorts and somewhere there is a 18 second timer that I've not located yet I need to adjust.
 
Does anyone have any experience with this that can shed some light?
 
Thank you,
Bill Westby
Medtronic Diabetes
UCCE 7.5, CVP 7.0, CUCM 6.1

Subject: RE: ICM Label Transfer Timeout
Replied by: Bill Westby on 13-09-2010 05:42:44 PM
Well found out how to transfer off-site and not timeout but now have new issue, don't hear ringback while destination number (PSTN number) is ringing, ?????   Any thoughts?
 

To solve the off-site blind transfer issue all I had to do was in my ICM Script, just before the label node I inserted a SET node:
Call Variable  user.sip.refertransfer 
Set value to "Y"
 
Now if I can figure out why I don't hear ringback I'm golden.

Bill Westby.
Comments

The label node also follows the RONA settings. So if your call is disconnecting exactly after 18 seconds, i believe there is some RONA settings configured for that pattern in cvp. You can try to increase this setting for each CVP using OAMP or under DialNumberPattern settings of OAMP for all CVPs. 

 

I faced this challenge once and fixed by increasing the time of RONA to one minute and it worked.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.