cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Is JTAPI 9 compatibile with older PBXs?

191
Views
0
Helpful
0
Comments
This document was generated from CDN thread

Created by: Stewart Ponsford on 25-03-2013 10:52:35 AM
I have an application built with JTAPI 7 library which works fine on CUCM 8 & 9.
 
There are some new features in JTAPI 9 I would like to make use of when using with CUCM 9 PBX.
However when my app is built for JTAPI 9, it doesnt connect to CUCM7, I get an error about invalid header info on getProvider. Can I maintain one build or do I now have to split the build and deploy depending on the target CUCM verson?

Subject: RE: Is JTAPI 9 compatibile with older PBXs?
Replied by: Abhishek Malhotra on 16-05-2013 08:31:13 PM
CUCM upgrades are backward compatible with JTAPI applications(in allowed upgrade paths) but not forward compatible.
So, with older JTAPI version you can connect to newer CUCM, but with Newer JTAPI cannot connect to older CUCM