cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays

lineOpen call fails after LINE_CRATE event

29
Views
0
Helpful
0
Comments
This document was generated from CDN thread

Created by: Dimitar Petrunov on 29-06-2010 12:36:27 PM
Hello,
 
I'm using TAPI for call monitoring on a CUCM v. 7.1.5. Everything works fine if I start my piece of code when CUCM is up and running, the lines get opened and I'm able to monitor the call activity. If i start my software before CUCM is started I'm unable to open any lines which is fine, then when CUCM starts I receive LINE_CREATE messages and I try to open the lines for which I receive them. Strangely the lineOpen call fails with LINEERR_RESOURCEUNAVAIL error code. Before the fail I'm able to negotiate the API and Extension version and even successfully call lineGetDevCaps. In both cases (when things work and when don't work) the code goes through the same path so I don't know what I'm missing.  Any Ideas?
 
Thanks

Subject: RE: lineOpen call fails after LINE_CRATE event
Replied by: Axel Becker on 29-06-2010 12:44:44 PM
Test it with a sleep of 250ms before calling lineOpen

Subject: RE: lineOpen call fails after LINE_CRATE event
Replied by: Dimitar Petrunov on 29-06-2010 02:07:43 PM
Test it with a sleep of 250ms before calling lineOpen

 
 
Thanks. I have tried it with 250 ms sleep and managet to open 2 lines out of 6. I'm going to try it with a 1 second value tomorrow. Is there some explanation behind that or a more elegant solution?

Subject: RE: lineOpen call fails after LINE_CRATE event
Replied by: Axel Becker on 30-06-2010 10:24:26 AM
I did not test it with a complete restart of the CUCM. But I had some problems with a single LINE_CREATE and there 250 ms was fine. May be internaly not all is created when you get the LINE_CREATE. Sometimes we need some sleep. ;)
Content for Community-Ad

This widget could not be displayed.