cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays

One or more telephone device drivers are incompatible with tapi.dll

6259
Views
0
Helpful
15
Comments
This document was generated from CDN thread

Created by: Engineering Department on 03-05-2012 07:01:11 PM
My customer is trying to use the Cisco 8.6 TSP with Windows 7 64 bit. We have the TSP installed and configured correctly. When we launch dialer to test it, we get the following error:
 
“one or more telephone device drivers are incompatible with tapi.dll.  install an updated version.”
 
Has anyone experienced this and if so, how have you gotten past it?
 
Thanks.
Dustin

Subject: RE: One or more telephone device drivers are incompatible with tapi.dll
Replied by: Thomas Dravecz on 10-05-2012 03:05:12 PM
I also have this problem, and have not found a solution. I am also using Cisco 8.6 with Win 7 64 bit.

Subject: RE: One or more telephone device drivers are incompatible with tapi.dll
Replied by: David Staudt on 15-06-2012 05:57:43 PM
Which specific version of Win 7 and service pack are you using?  There are 32-bit and 64-bit versions of the TSP available on UCM, have you confirmed the 64-bit version is the one installed?
Comments
rpbarham
Beginner

Hi Dustin,

Can you tell me if you did get the tapi issue resolved, we are having the same issue using Win 7 as well, and want to know what was your resolution.

Michael Schmidt
Beginner

Hi,

we are facing actually the same problem with Cisco 8.6 TSP and Windows 7 64 bit ->

“one or more telephone device drivers are incompatible with tapi.dll.  install an updated version.”

But when we start the "dialer.exe" in Windows 7 as Adminitrator the dialer.exe works as expected and we can select the associated devices from the enduser without any error.

But when we start the "dialer.exe" without Administrator rights we still get the mentioned error to update tapi.dll although we installed the TAPI which we downloaded from CUCM 8.6

How can we solve this problem because the most of the users doon`t have Admin rights to the PC`s?

BR

Michael

npetrele
Cisco Employee

Try something other than dialer.exe.  When dialer.exe produces that error for me, other TAPI software dialers work fine. 

Michael Schmidt
Beginner

Did you also had this problem with "dialer.exe"?

What other software are you using at the moment? 3rd party software?

BR

Michael

npetrele
Cisco Employee

Yes, I had this problem with dialer.exe.  I think you can also solve this by going into Control Panel -> Phone and Modem -> Advanced and removing Microsoft HID Phone TSP.  Then you should be able to use dialer.exe again.

Let me know if that works for you.

Here's an alternative TAPI phone (free).  It's pretty geeky (I prefer dialer.exe when it works). 

http://www.julmar.com/tapi/native-tapi-samples/tapi_soft_phone.zip

Michael Schmidt
Beginner

Thank you for your reply. Removing / deleting Microsoft HID Phone TSP didn`t help to solve the problem with "dialer.exe".

But I will try your free TAPI phone.

BR

Michael

Michael Schmidt
Beginner

Hi Nicholas,

your TAPI phone is working without error although the user has not admin rights but the customer is using Novell Groupwise and this Novell Groupwise always want to use the "dialer.exe".

Do have any idea to solve the problem with "dialer.exe"?

BR

Michael

npetrele
Cisco Employee

Hi Michael,

So far, the solution above (removing the Microsoft HID) always works for us with 64-bit Windows 7.  Which version of Windows is your customer using?  Is your customer installing the right version of TSP from UCM? 

I will also check with the TAPI team on this. 

Nicholas

Michael Schmidt
Beginner

Hi Nicholas,

I was on site at the customer today and tried your solution but it was not working.

The client at customer site is "Win 7 Pro SP 1 - 64 bit".

Yes the TSP version is the correct one for 64 bit which I downloaded from CUCM 8.6 at customer site.

BR

Michael

npetrele
Cisco Employee

Hi Michael,

The team is still investigating this.  If you can gather any logs, like system event logs when the error happens, that might help us find the problem.  It seems to only show up with dialer.exe, and it really doesn't seem to have anything to do with Cisco TSP (even though installing Cisco TSP seems to trigger it, although if google results are any indication, other TSP installations trigger it, too), so it's difficult to track down.  I would try the following:

1. You already tried removing the Microsoft TSP from Phone and Modem, but I'm listing it here because that also works for some people.

2. Try #1 and then run Dialer.exe as Administrator, select a line and make a call.  For some inexplicable reason, this seems to clear the problem permanently on some systems.

3. Apply registry changes using the linked file below.  Right click on the file and choose merge. Then answer the security question.  Some people have have had success with these registry changes.

Here's a link to download the registry change file TAPISRV_exclusive_Mode_with_LocalSystem.reg

FTP Download Tapisrv Exclusive Mode With Localsystem.reg

These solutions could be cumbersome if you have to make changes on a lot of systems.  We'll keep searching for other solutions.

Nick

npetrele
Cisco Employee

Okay, I think I finally have an answer to the dialer.exe problem.

1. Run dialer.exe.

2. Go to Tools -> Connect Using and select a Cisco line.  (Click OK out of any driver errors you see.)

3. Don't bother setting the address, since it won't give you a choice if you're getting this error.  Just click OK.

4. Now exit dialer.exe.

5. Run regedit and go to HKEY_CURRENT_USER -> Software -> Microsoft -> Windows -> CurrentVersion -> Dialer

6. Preferred Address is probably set to -1.  Set it to 0.

7. Run dialer.exe again.

Voila.  No more incompatible driver errors.

npetrele
Cisco Employee

Okay, I think I finally have an answer to the dialer.exe problem.

1. Run dialer.exe.

2. Go to Tools -> Connect Using and select a Cisco line.  (Click OK out of any driver errors you see.)

3. Don't bother setting the address, since it won't give you a choice if you're getting this error.  Just click OK.

4. Now exit dialer.exe.

5. Run regedit and go to HKEY_CURRENT_USER -> Software -> Microsoft -> Windows -> CurrentVersion -> Dialer

6. Preferred Address is probably set to -1.  Set it to 0.

7. Run dialer.exe again.

Voila.  No more incompatible driver errors.

Michael Schmidt
Beginner

Hi Nicolas,

sorry for the late reply but I was on holidays.

I just had a look at your solution but can`t any "Preferred Address" entry at HKEY_CURRENT_USER -> Software -> Microsoft -> Windows -> CurrentVersion -> Dialer

I only have the following entries at HKEY_CURRENT_USER -> Software -> Microsoft -> Windows -> CurrentVersion -> Dialer:

- (Standard)

- Last dialed 1 until 20

- Main Window Left/Top

I just created manually a DWORD "Preferred Address" and set it to 0 but this doesn`t help.

Do you have a entry called "Preferred Address" at HKEY_CURRENT_USER -> Software -> Microsoft -> Windows -> CurrentVersion -> Dialer and what type this "Preferred Address" is?

BR

Michael

npetrele
Cisco Employee

This is what it looks like in regedit:

https://33.media.tumblr.com/7bed6388ded691ebf66e729434831b03/tumblr_nbqrysB5Vb1rmfjwko1_500.png

If you don't even have entries for Dialer, then I think Dialer is the whole problem, and I have no clue about what Microsoft does with Dialer. 

Michael Schmidt
Beginner

Hi Nicholas,

sorry for the late reply.

I tested this today and it works for me fine. Thank you very much.

I will ask the user to test this next week when he is back in the office.

BR

Michael

Content for Community-Ad