Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

Studio Licensing Dramas- Audium Home Directory

This document was generated from CDN thread

Created by: David de hennin on 13-01-2009 11:08:34 PM
Hi Guys, I am helping a customer get set up on Studio to start a project.
He is getting a licensing error even after sucessfully activation Studio through manual activation.Persistant licence.

Description of the problem :
The registration of "Call Studio" using "Installation Key" and "License Key" has run successfully. But when I want to launch the "debugging tool"
of my project , I have an error message in the "debugging tool console" :

Audium Home Directory:
\AUDIUM_HOME . The Installation Key is missing or invalid. Please set a valid Installation Key.

NOTE this installation has sucessfully activated.
Any one seen this before or know the issue?
Any help appreciated .


Subject: Re: Studio Licensing Dramas- Audium Home Directory
Replied by: Janine Graves on 14-01-2009 07:33:31 PM
Regarding Studio Debugger:

I'm pretty sure you can just ignore that error message. I think it has to do with the fact that Studio now has a 'Call Services' and Tomcat installed (that's how the Studio Debugger works). I've gotten that error message in the Debug window, but then when I press the CONNECT button on the right-bottom pane, I can run the application.

1.To run the debugger, I right-click the application name in the Studio Navigator window (upper left), and select 'Debug Call Studio Project'

2.The Debug View displays. Wait until you can press 'Connect' in the Application-pane of the Debugger window (bottom right).

3.When done debugging, you should click on the red terminate button in the bottom-left (Console) window and then also at the top of the Debug window.

4.To exit the Debugger view, press the Builder button in the upper-right corner

Occasionally, the Connect button won't become enabled, so I have to restart Studio.


Subject: Re: Studio Licensing Dramas- Audium Home Directory
Replied by: Rachel Yang on 15-01-2009 10:47:22 PM
That's right, the message is just a warning as an eval-licensed VXML Server (or "Call Services" in UE terms) must be bundled in Call Studio in order for the debugger to work. The warning can be ignored and will not impact any functionality of the debugger.

Community Member


I'm getting this same error. I am using the evaluation version of Studio. However, I only get this error when I place a class file in the AUDIUM_HOME/common/classes folder. Are we not allowed to do that in the evaluation version? I was doing a proof of concept and need a class file there so I can retrieve it out of the application object (throws a casting exception if it is not in the common folder).

I cannot ignore this error because it prevents the StartApplicationInterface from running.

Rising star

Evaluation version doesn't affect whether it works or not. What version

of Studio are you using?

And what is the error exactly?

Try exporting your class file from Studio into a Java/jar and then place

the jar in AUDIUM_HOME/common/lib. If you still get an error, tell me

what the exact error says.

Community Member


Thanks for the response. I enjoyed your CVP Java class last year and it's good to hear from you again. I'm running 7.0.1, build 200802122108 and waiting for my large organization to buy a license for me.

I have a custom communication with an external from CVP application. I wanted the software object that does the communication to be shared for all calls coming in so I am trying to store it in as an Application object. I can't get that to work so I tried a very simple object. Here is what I'm seeing:

I have a StartApplicationInterface object. In the onStartApplication method I store a boolean as Application Data, and a simple dummy object also. Here is how I store them:

boolean TestValue = true;

appData.setApplicationData("qTestBool", TestValue);


DummyObject d = new DummyObject();

appData.setApplicationData("qTestObject", d);

I can pull them both right back out inside the onStartApplication method and that works fine. My code looks like this for the DummyObject:

  Object testObject = appData.getApplicationData("qTestObject");

  System.out.println("1 ....Hit This Line.... ");

  if(testObject == null){

  System.out.println("1 ....Test Ojbect is NULL.... ");


  else if(!(testObject instanceof DummyObject)){

  System.out.println("1 ....Test Ojbect is NOT CORRECT CLASS.... it is:'"+testObject.getClass().getName()+"' instead of '"+DummyObject.class.getName()+"'");



  DummyObject d2 = (DummyObject)testObject;

  System.out.println("1 ....Test Ojbect is was put into object of type dummy.... ");

  int i = d2.IntValue;

  System.out.println("1 ....Test Ojbect IntValue: "+ i);

  boolean b = d2.DidWork;

  System.out.println("1 ....Test Ojbect DidWork: "+ b);


Everything is fine, I see the lines printed with the DummyObject data. Then I try getting it out in the CVP application and it just does not work. I have a custom element extending ActionElementBase. In the doAction method I can pull out the Boolean just fine. However, when I use the exact same code (except using data.getApplicationAPI().getApplicationData("qTestObject") ) to get the DummyObject it throws an exception. The exception is: "Error:java.lang.ClassCastException:". If I get the class name of the object I pull out of getApplicationData it has the correct name of

I read on a different post this is caused by not having the Java class file in the AUDIUM_HOM/common/classes directory so the JVM can't create an instance of the class. So I go to the directory and copy the the DummyObject.class file there. If I do, then I get an error upon startup that prevents my code in the onStartApplication method from running. That error is:

"Audium Home Directory: C:\Cisco\CallStudio\eclipse\plugins\\AUDIUM_HOME

The Installation Key is missing or invalid. Please set a valid Installation Key."

If I remove the class from from the directory, the error goes away but I can't get my object out again.

UPDATE: If I use a jar instead of a class file, the license error goes away. When trying to cast the object though I still get "Error:java.lang.ClassCastException:"

Thanks again for your time!


Rising star

Hey Steve,

Studio 7, huh? I think Studio 7 Debugger had problems.

I recall seeing that error a long time ago. And I'm not sure how I

resolved it.

But the Debugger's AUDIUM_HOME/common/classes directory now contains a

file called keep_empty_directory.tmp. So perhaps you're not supposed to

use that directory.

The common/lib directory might work for you if you create a jar file.

Could you try taking your class and convert it into

a Jar file (from Studio Navigator, right click and select Export > Java

> Jar) and store the jar file into AUDIUM_HOME/common/lib directory?

See if that solves the problem?

Community Member


We use CVP 11, and this is the studio version we use. If I go to Help -> About, that is the version listed. Is this not a recent Studio version? My directory DID have that keep_empty_directory.tmp file.

Using the "lib" directory instead of "class" directory solved it for me though. So to clarify, if we store a class as an Application object and access it from different Java classes, not only do we need to include the class file in the deploy/java/classes folder, we also need to put the used classes into a jar file and dump them into the AUDIUM_HOME/common/lib directory.

Thank you for your help! I was struggling getting this one to work.


Rising star

Here's a screen shot of the Studio 11.0 Help>About which you should probably use with CVP11 - Build 20150911404

Rising star

I believe that custom object classes that are used in the AppStart (or

Call Start) class and the Session api (action and decision elements,

etc) must be stored in VXMLServer/common (or AUDIUM_HOME/common for the


And since Studio Debugger (for some strange reason) 'sometimes' (some

versions) doesn't like class files in its AUDIUM_HOME/common/classes,

you must use *jar files in AUDIUM_HOME/common/lib*.

Tto keep things 'consistent' you should probably use the jar file

(rather than the class file) in the VXMLServer/common/lib (although

VXMLServer is fine using class files).

FYI, if you have a jar file defining a Studio Element or SayItSmart,

then you can make it 'common' (global) by putting it into

CallStudio\eclipse\plugins\\ directory.

But if you're just defining an object class, this is not necessary.

Now - after all that, you will no longer need the object class (or lib)

in the Studio app's *deploy/java/application/ *folder because Studio,

VXMLServer, and the Debugger load classes defined in the common

directory first, and ignore that in the application's 'java' folder if

the same class name is found in both.


Content for Community-Ad