cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Web Services Element won't load WSDL

480
Views
0
Helpful
0
Comments
This document was generated from CDN thread

Created by: Neil Fluhr on 23-10-2012 09:58:52 AM
Hi, I'm trying the Web Service element for the first time in Call Studio 8.5. I pasted the URI but when I click on the "Load" button nothing happens. No error message or anything.   The URI is in the format "http://hostname:port/servicename?wsdl"
I had no issues accessing the WSDL in another browser. I even saved it to a file and tried loading the file with the same result.
This is referencing the 1.1 namespace - http://schemas.xmlsoap.org/wsdl/
 
Has anyone else had a similar experience?

Subject: Automatic reply: New Message from Neil Fluhr in Customer Voice Portal (CVP)
Replied by: Deepak Gupta on 23-10-2012 10:00:08 AM
Hi

I am on PTO from 23 Oct 2012 till 24 Oct 2012. Thereafter, I will be on business travel from 25th Oct 2012. I will rejoin the local office starting 5th Nov 2012.

During the travel duration I will have limited  access to mails/phone and as such, my responses might be delayed.  Please drop me a message and I will try to respond back to you as soon as possible.

If this is regarding an ongoing Advanced Services project then please reachout to the designated Cisco Project Manager for anything urgent.

Regards,
Deepak Gupta
Email: deepagup@cisco.com
Phone: +91 9899248292

Subject: Re: New Message from Neil Fluhr in Customer Voice Portal (CVP) - General Di
Replied by: Janine Graves on 23-10-2012 11:02:15 AM
use a web browser and paste in that same URL. It should display the wsdl.
Then right-click and select View Source.
Save the wsdl to a file.
Then in Studio, try to load the wsdl from the file.
If you can't then the wsdl isn't in the right format.

Subject: RE: Web Services Element won't load WSDL
Replied by: Neil Fluhr on 26-04-2013 01:02:50 PM
Thanks, Janine. Looks like it's not in a supported format.

Subject: RE: Web Services Element won't load WSDL
Replied by: Bill Albano on 07-05-2013 11:46:11 AM
Hi Neil (or Janine)
 
The WSDL file I have is written in xml.  Our client is providing a WADL file.  When comparing the file to a generic wsdl file (from W3.org) it shows .wsdl extenion names in the namespace declaration.  However the WADL file does not.  Is there a specific format example? 

Subject: RE: Web Services Element won't load WSDL
Replied by: Hemal Mehta on 09-05-2013 07:59:18 AM
I do not believe you can load WADL file in studio.  With WADL you can generate the java code using command line tool.

Subject: RE: Web Services Element won't load WSDL
Replied by: Tom Shaw on 05-09-2013 11:24:39 PM
Hemal Mehta:
I do not believe you can load WADL file in studio.  With WADL you can generate the java code using command line tool.

How can you use the CLI in order to reference the WADL?  We are trying to query a webservice and return the results to the CVP application but it is in REST and uses a WADL which will not load in Call Studio.  Thanks.
CreatePlease to create content