cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Wsdl sample?

160
Views
0
Helpful
0
Comments
This document was generated from CDN thread

Created by: Janine Graves on 08-08-2008 12:42:23 PM
Does anyone have a web services wsdl file they've managed to load into Studio for cvp 4.1 or 7? The samples I've tried downloading from the internet are all rejected by Studio - presumably they are the wrong version.

also, does anyone have a sample web service they'd like to share or recommend I download for demonstrating in the classroom?

Thanks, Janine

Subject: Re: Wsdl  sample?
Replied by: Kamesh Chidambaram on 16-09-2008 03:40:29 PM
I am trying to use the WebService node with a valid WSDL but the CVP doesn't seem to like it. I wonder if its related to the same problem you faced. When I tried to update my application after including a webservice node, I get the following error.

Error with admin application update,09/16/2008 11:17:17.934,An error has occurred. The error was: java.lang.NullPointerException
java.lang.NullPointerException
at com.audium.server.webservices.ServicesConfiguration.createBindingOperation(ServicesConfiguration.java:160)
at com.audium.server.webservices.ServicesConfiguration.init(ServicesConfiguration.java:143)
at com.audium.server.webservices.ServicesConfiguration.<init>(ServicesConfiguration.java:120)
at com.audium.server.controller.AudiumServerConfiguration.parseWSDLs(AudiumServerConfiguration.java:305)
at com.audium.server.controller.AudiumServerConfiguration.<init>(AudiumServerConfiguration.java:211)
at com.audium.server.controller.AudiumServerConfiguration.initialize(AudiumServerConfiguration.java:841)
at com.audium.server.controller.Admin.cmdUpdateApp(Admin.java:287)
at com.audium.server.controller.Admin.executeCommand(Admin.java:218)
at com.audium.server.controller.Admin.run(Admin.java:1247)
at com.audium.server.licensing.LicenseManager.run(LicenseManager.java:215)
at java.lang.Thread.run(Thread.java:595)

This seems to be the error, whichever WSDL I use.

  • Are there any other steps or libraries required on the server side?
  • Are there any other ways of troubleshooting WSDL files?
kamesh

Subject: Re: Wsdl  sample?
Replied by: Janine Graves on 17-09-2008 06:19:41 PM
No, I got error messages just trying to point Studio to the wsdl file.

Your error looks more like something within one of your webservices
elements. Perhaps some entry in one of your w-s elements needs to be filled
in (required field) but wasn't filled in.

Try to simplify your application. Include just one web services element
and see if you can get the updateApp script to run. If so, then add the
next one, and so on.

Subject: RE: Re: Wsdl  sample?
Replied by: Kamesh Chidambaram on 19-03-2009 03:09:31 PM
 
Hmm.  I forgot to post an update on this thread.
 
I was facing this issue due to version incompatbility.   Both the server and client has to be on CVP 7.0(2) for Web Services to work.  Apparently there were some Web services related fixes on 7.0(2).  Note that the 7.0(2) patch for CVP Studio is a different exe from the patch installed on the server.
 
I was able to pass parameters only if the WSDL heirarchy was limited to one or two levels.   If you have a fairly nested XML request in say 3 or 4 levels, CVP Studio was unable to substitute variables in the request.  It worked fine with static parameters which is rarely useful.  This turned out to be a bug and got a ES to get around this issue.
 
regards,
Kamesh
 
 
 
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here