cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Call drop after 25 seconds

10554
Views
0
Helpful
3
Comments

Hello,

Have you suffer a call disconnection after 25 seconds?

debug voip ccapi inout

Aug 21 11:19:15.018: //861/80CEC8490A00/CCAPI/cc_api_call_disconnected:

   Cause Value=41, Interface=0x49F63A88, Call Id=861

In my case I did and this was the solution:

The following example uses the ip rtcp report interval command to set the reporting interval to 5000 milliseconds, and then the timer media-inactive command to set the multiplication factor to 10. The result is that calls detected as inactive for 50 seconds (5,000 milliseconds times 10) will be disconnected.

Router(config)# ip rtcp report interval 5000

Router(config)# gateway

Router(config-gateway)# timer media-inactive 10

Router(config-gateway)# exit

EXPLANATION

When the timer media-inactive command is used, the gateway uses the inactivity timer as a combination of thetimer media-inactive command and the ip rtcp report interval command. The timer media-inactive command uses DSP statistics. This capability is based on the configuration of callfeature parameters using application command-line interface (CLI) to enable control.

The media are considered inactive only if there is no transfer of RTP packets in the send direction and no RTP packets in the receive direction. If RTP is present in either the send or receive direction, it is considered active. In this mode, DSP filters out any comfort noise packets, and the presence of any comfort noise packet is considered inactivity in either direction.

The multiple argument (or multiplication factor) is multiplied by the interval that is set using the ip rtcp report interval command. This command configures the average interval between successive RTCP report transmissions for a given voice session. For example, if the value argument is set to 25,000 milliseconds, an RTCP report is sent every 25 seconds, on average. If no RTP packets are received during the calculated interval, the call is disconnected. The gateway signals the disconnect to the VoIP network and the time-division multiplexing (TDM) network so that upstream and downstream devices can clear their resources.

Before doing that verify also in the Call Manager:

Devices > Gateway > MTP (has to be check)

source: http://www.cisco.com/en/US/docs/ios/voice/command/reference/vr_t2.html#wp1644723

Comments
Bill CARTER
Contributor

Thanks. I just ran into this problem. I had:

ip rtcp report interval 5000

!

gateway

timer receive-rtcp 5

!

I had calls disconnecting after 20 seconds, often in mid-conversation. Funny how none of the documentation mentions needing the MTP checked.

Cesar Ortega
Beginner

Hi Bill,

Actually is not mandatory to have MTP checked on the Call Manager. This feature duplicates the flux of RTP packages which is not desired in WAN connections. So normally it should be unchecked to avoid undesired traffic.

In the other hand, you can use if not WAN connections are being used.

Finally, by checking MTP, you did solve your issue?

Cesar

Cesar Ortega
Beginner

Hi everybody,

I finally figured out with TAC Support the real cause of the issue (not MTP on the CM nor ip rtcp report interval).

On the gateway apply:

# config t

(config)# gateway

(config-gateway)# no timer receive-rtcp 6

(config-gateway)# no timer receive-rtp 1200

(config-gateway)# no media-inactivity-criteria all

These commands are configure to check for the media inactivity[ if no RTP and RTCP packets are received by the gateway] and to tear down the hung up calls if in case and sends the disconnect to PRI [ PSTN] and release complete to PBX or CUCM.

Normally MTP should be unchecked (CM) to avoid duplicated RTP packets on the WAN.

Good luck!

Cesar

Create
Recognize Your Peers
Content for Community-Ad