Showing results for 
Search instead for 
Did you mean: 

Cisco Jabber Integration Plug-In for Lotus Notes


Hi Everyone.

I recently came across an IBM code sample for "Live Text Actions" in Lotus Notes.

So I added some code to it to start Cisco Jabber Client when you click a phone number in notes.

You can find the original code sample here:

What it does:

It basically integrates into Notes Live Text.

So if you click a Phone Number anywhere in Notes, the Plug-In checks:

  • If you have a 32 or 64-bit Windows
  • If "CiscoJabber.exe" is present and readable in either

           C:\Program Files (x86)\Cisco Systems\Cisco Jabber


          C:\Program Files\Cisco Systems\Cisco Jabber

If the Jabber Client is present, the Plug-In executes it with:

CiscoJabber.exe -URI tel:phonenumber

I have tested this Plugin with:

  • Lotus Notes 9.0 Social Edition
  • Lotus Notes 8.5.2
  • Cisco Jabber 9.1
  • Cisco Jabber 9.2

both on 32 and 64-bit systems.


For this PlugIn to work, Widgets AND Live Text have to be enabled in Notes.

To install the Plug-In, make sure you have the necessary rights to install applications in Lotus Notes.

  • Click: File -> Applications -> Install
  • "Search for new features"
  • Add Folderposition
  • Choose the "UpdateSite" folder provided in my .zip file
  • Install the Plug-In

I would be happy to get some feedback.

Update 24.04.2017:

Seems like there is some problem with newer Notes versions or Notes Fixpacks where Java Processbuilder adds double quotes to the parameter passed to CiscoJabber.exe.

Updated Plugin to 1.1.6 which should resolve the issue.

Update 08.05.2017:

Switched from using String to String[] to build the Process for Runtime.exec.

Updated Plugin to 1.1.9

Ben Morgan

Hi Michael,

This looks ok, I will configure in a couple of weeks and test. I was going to use the below link to configure a notes widget..

Will provide feedback

Michael Reiner

I tried this widget too but I had way to much trouble with it, especially with newer notes versions.

Authorization with the webdialer didnt work most of the time, and the interface was just plain awful .

And you have to manually configure it with the webdialer credentials on every notes client.

The nice thing about my plugin, and essentially why I developed it, is, you do not have to configure anything locally on the client, and you can distribute notes plugins via domino automatically.

So if you have a large amount of notes clients, you can roll out lotus notes click-to-dial very easily.

Community Member

Hi Michael,

I want to test out installing this plugin remotely, can you tell me the process you used to install it? It doesn't seem to straight forward to install on a standard users PC - especially if they do not have local admin rights to their PC


Michael Reiner

Hi Murray.

You don't need local admin rights on your PC to install this plugin. But you do need to have the rights in lotus notes to install applications.

Since I am not a domino admin, I have no idea how you could install the plugin remotely.

But you can put the "UpdateSite" folder on a webserver an install the application in notes via http.

In the dialog where you add the folder location, you then choose a remote folder location instead of a local one.

EDIT: Just found a documentation on how to install applications and features in notes.

Maybe this will help:

Mike Schuster

Just installed the plug-in, works great!

One question though... my Notes client seems to be formatting the phone numbers as +ten digits (+2345551212). Is there a way to modify this? My dial plan in CUCM allows for straight 10 digit dialing, or with a +1 prefix.

I am able to work around this by adding a route pattern for \+.[2-9]XX[2-9]XXXXXX and stripping pre dot, but I'd prefer to change the way Notes sends the number out.

Michael Reiner

Hi Mike.

I compiled a version where I removed the code regarding number manipulation (removing trailing zeroes, adding "+", etc)

Please test it and see if this fits your needs.

Community Member

Hi Michael,

This seems very useful, is there any chance of getting the plugin where it does not add the "+" to the beginning of the number? 

I am an admin and not really a developer, I have tried figuring out how to modify the code and I spent quite a few fruitless hours in the attempt.




we have implemeted the Livetext Plugin. Since Jabber Version 11.X the plugin doesnt work anymore. Any ideas? Is it a Jabber issue or a livetext issue?


Michael Reiner


It should work with 11.x. In fact i have a lot of installations with Jabber 11.8 and 11.7 running.

As long as Jabber is installed under 
"C:\\Program Files (x86)\\Cisco Systems\\Cisco Jabber\\CiscoJabber.exe" on 64 Bit
"C:\\Program Files\\Cisco Systems\\Cisco Jabber\\CiscoJabber.exe" on 32 Bit, it should work.

The plugin then calls CiscoJabber.exe -URI tel:phonenumber


Hello Mr Reiner,

thanks for your feedback.

The Jabber is installed on this location. But doesnt work. Can you provide me your plugin?




Michael Reiner

I still use the same version that i posted here. (See attachment on first post)

Michael Reiner

Hi. After a few tests, it seems there is a problem with some recent Notes Fixpacks. I updated the Plugin to 1.1.6 (see attachment on first post).

Please try it and see if it works now.



the plugin works fine. Almost perfect :-) On few clients we get following message if i click on a number.

Any idea?


Michael Reiner

Weird. Seems like CreateProcess tries to run "C:\Program" instead of the complete Jabber Path "C:\Program Files(x86)\....."

Please run ProcessMonitor on the affected System, and check exactly what process is started.

It should look like this:


I think I found the problem. I uploaded version 1.1.9 to the original post. Please try if this works now.

Content for Community-Ad