Showing results for 
Search instead for 
Did you mean: 

Database connection test failed-DMA fails

CM : 4.1.3 
Whenever we tried to export through DMA,it fails with the following error
message "Database connection test failed"

We had tried to uninstall the DMA and reinstall it again but it fails at the same point.

It seems while taking a DMA, the following service gets stopped "Informix
IDS ccm"


[09:14:32 PM]   The database connection test has failed.

Please check and make sure the 'Informix IDS - ccm' service is running.

This may also be caused by an improper DMA installation or other connection

So you may try the following:

Logged out from Administrator
  + Logged in as Informix
  + Saved a copy of the C:/Informix/etc/ONCONFIG.ccm
  + Edited the C:/Informix/etc/ONCONFIG.ccm to
  + + set the PHYSFILE to 2000
  + + set the LOGSIZE to 2000
  + Started a 1st Command Shell and executed
  + + call C:\Informix\ccm.cmd
  + + oninit -ivy               (NOTE:  this hangs until the onmode
  + Started a 2nd Command Shell and executed
  + + call C:\Informix\ccm.cmd
  + + C:\CiscoWebs\DMA\bin\dbcmds.cmd
  + + onmode -yuk
  + Copied the saved copy of the C:/Informix/etc/ONCONFIG.ccm back to the
original location
  + Checked that I could start the services manually
  + Restarted the server
  + Checked that the Informix services all came up automatically
  + Started DMA

This should helps...

Hi Hayant

I followed the procedure, but it did not work... i could not run the command "onmode -yuk" just ran the command C:\CiscoWebs\DMA\bin\dbcmds.cmd, did you resolve the problem whith the DMA using the previous procedure?

Do you know if this is an identified Cisco Bug?

Cisco Employee

Hello Carlos,

Hope you are doing well.

Yes, it did resolve the issue. I hope the conditions are similar to what i experienced.

Please check if in the ccm.log () you are getting following message : I/O error, Primary Chunk 'C:\IFMXDATA\ccm\rootdbs_dat.000' -- Offline (sanity) and IBM Informix Dynamic Server Stopped.

There are no specific Bug which Cisco has identified as if now.

Please ensure you run the follwoing command "onmode -yuk" on different command prompt window.




DMA Fails at Checking Informix IDS - ccm

When you upgrade from Cisco CallManager 4.1(3) to Cisco Unified Communications Manager 7.x, the DMA fails with the Error connecting to Database error message. The DMA starts, and at the same time stops at the Informix IDS - ccm service, which results in this error.


In order to resolve this issue, stop the Informix Server Discovery process for SNMP after you restart the Publisher server. If this service is stopped before you start the DMA , the Informix IDS - ccm service continues to run, and the migration is successful.

Another solution is to change the Informix Server Discovery process for SNMP service to manual, and let the Informix IDS - ccm remain as automatic. After which, restart the server, and then re-run the DMA.

Community Member

I have been searching all over the place trying to find a solution to this. This is the second suggestion of this that I have found today. I'll try it out and let you know how it works.


For what it worth to whomever finds this, the Solution provided above by "brobinson" worked like a charm.  Set the stop the ISD SNMP service, start the IDS - ccm service and run the DMA.  Thanks!