Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

Enterprise Group configuration for jabber



With Cisco Unified Communications Manager Release 11.0, Cisco Jabber users can search for groups in Microsoft Active Directory and add them to their contact lists. If a group that is already added to the contact list is updated, the contact list is automatically updated.This document will explain the procedure to achive the same.


1.Enable enterprise group configuration in CUCM enetrprise parameter:

Navigate to CUCM admin page >> System >> Enterprise parameter >> Choose CUCM publisher >> Search for the parameter "Directory Group Operations on IM and Presence" >> Enable it

2.Create Distribution Group in LDAP

3.Make sure the required users are added to the group

4. Configure CUCM to sync both users and Groups. Navigate to CUCM admin page >> System >> LDAP >> LDAP Directory and configure for Users and Groups. Perform sync once after configuring

5. Make sure the Groups are synced. Navigate to User Management >> User Settings >> User Group

6. Login to jabber and search for directory Group : File >> New >> Directory Group >> Saerch for the group and add


Can see the Group is added and users who are part of groups are also added



Excellent write up! A few screenshots make a big difference.

Are Group Referrals (i.e. nested group memberships) supported? My understanding is that referrals are not supported and the user must be a direct member of the group to be shown in Jabber but I wanted to verify.

Marucho Mendez

Great instructive.

I've tested the feature but there is a must that it need to have. 

There is not way to bulk add a directory group to a bunch of users or enterprise wide. First when the users requested this feature was thinking in simplify the Jabber adoption but now we are almost like the beginning, we are able to add a group ("nice") but they needs to be added user by user basic ("no so nice").

Expecting to have this feature in the near future.



Nishant Savalia

I have been doing the same way but unfortunately Jabber is not able to search under "Directory Group" option. It always shows up as "no result found".

I can see the group has been populated in CUCM under user management --> user setttings --> user group.

Hi Nishant,

You have any special characters or () in your group name?


Hi Marucho,

Thanks for the feedback, but currently this feature is not available.


Hi Jonathan,

Thanks. As far as i know group refferal is not supported, also there is not an official document available on this at this point of time.


Nishant Savalia


No there is no any special character in group name. In fact i have named it as test and it does populate under user group of CUCM.

Robert Bustamante

 Why can’t we use Email Enabled Security Groups?  

I can get this to work with our distribution groups but when I make it a security group and then I search for the group it does not populate in the search window.

Frequent Contributor

I have the same, what was your solution?

On iPAD it worked immediately, windows not




Has anyone solved this issue?  I followed these steps and can see the group in CUCM but i'm unable to find any of the groups from Jabber while searching.

Do I need to be using UDS for directory search or should EDI directory search work?


Guillaume Roche


I have no "File >> New >> Directory Group >> Search" in Cisco Jabber 11.

How to have this option ?


Best regards,


Thanks for the write up, is there a way to restrict who can send IMs to a particular group once this is enabled? I know you can use the LDAP filter to control what groups show up but that is not exactly what I'm needing.


I've found the same problem, and also noticed that the name of the group seems to be case-sensitive.

Ben Morgan

Also check to ensure you have the correct LDAP Port configured. If you select Global Catalog under the UC Service configuration page, ensure the port is 3268.

Jose Goncalves

I have the same issue.

How did you solved it?