cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

How to migrate / redeploy from vTP 4.2 and earlier to vTP 4.3

932
Views
5
Helpful
6
Comments
Hall of Fame Cisco Employee

(view in My Videos)

 

 

In this video, I'll show you how to migrate / redeploy your vTP 4.2 and earlier to the new vTP 4.3

A few things to keep in mind:

A) You will need to have your root CA and server certificates as the procedure will NOT migrate them, and you'll need to upload them after the procedure finishes.
B) vTP has increased the minimum vRAM requirements from 12 GB to 16 GB, you need to take them into account for the host where it will be running.
C) TelePresence Server 4.2 was the last release to support Locally managed mode. From this release, 4.3(1.13) onwards Locally managed mode is no longer supported.
TelePresence Conductor is required to support the latest TelePresence Server releases and features.
D) You do not get to choose the host in which the new vTP 4.3 will be deployed, it will use the same host from the "old" vTP server, and will use the same datastore.

My test environment was:
ESXI 5.5U2 with Enterprise+ license
Windows 7 SP1 virtual machine with Python 2.7.11

The relevant documentation which you should also review, is this:

Cisco TelePresence Server Software Release Notes 4.3(1.13)
http://www.cisco.com/c/dam/en/us/td/docs/telepresence/infrastructure/ts/release_note/Cisco-TelePresence-Server-Software-Release-Notes-4-3-1-13.pdf

Migrating to TelePresence Server on Virtual Machine 4.3
http://www.cisco.com/c/dam/en/us/td/docs/telepresence/infrastructure/ts/install_guide/vTS-upgrade-redeployment-tool.pdf

You can find the downloads here:
https://software.cisco.com/download/release.html?mdfid=284962668&softwareid=280886992&release=4.2(4.23)&relind=AVAILABLE&rellifecycle=&reltype=latest

If the link breaks, the path at downloads is:

Downloads Home - Products - Conferencing - Video Conferencing - Multiparty Conferencing - TelePresence Server - TelePresence Server on Virtual Machine

 

Any questions, comment, etc. you can reach me at javalenc@cisco.com

6 Comments
Frequent Contributor

Hello Jaime

The instructions in migrating document are clear, but I never got the progress bar. Only after adding http://127.0.0.1 to the java security exception site list, did the migrate start.

The migration is done in minutes

Jan

Hall of Fame Cisco Employee

That's weird, I had to do nothing to Java settings or the browser for it to work without any issue.

Frequent Contributor

I tried several times, and each time I didn't see the progress bar. Only after adding the 127.0.0.1 in java security it worked. Still could be a weird issue, and I am running this on Windows 10, maybe a little different from Windows 7

Thanks for the video!

Jan

Frequent Contributor

Yes you are right, did something wrong, you have to click on "set all" Thought its was only needed if you have more than 1 telepresence server.

So, in my lab all worked well, now I am at customer site on an official BE6000 machine and I get this error (see attached file)

The ESXi is 5.5.0 2068190 which is 5.5 update 2, and the official license from Cisco is installed

Any idea?

Jan

Hall of Fame Cisco Employee

The video was the first time I did this, while I started to edit, I did it again, but this time without vCenter, just the host, and didn't use the set all, it worked fine for me.

I had a feeling that the ESXi licensing might come into play, that's why I mentioned what I used, the documentation does not mention anything regarding what licensing is required (But it hints that you might need to upgrade your vCenter, which means FND might be required), but it's obvious that it does something similar to PCD and uses some sort of API to do this.

Please open a case with us so we can look into it and then clarify, you can direct them to this video/thread for reference.

Frequent Contributor

Hello Jaime

Thank you for your help. In the mean time I reinstalled 4.3 and re-hosted the license. Configuration of Telepresence server is very simple, since most of the configuration and licensing is on Conductor and TMS/TMSPE

Thanks!

Jan

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here