cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

I need Firmware 4.1.10(b) because 5.1.8 doesn`t work with our telephon system

21
Views
0
Helpful
0
Comments

Hello together,

know anyone where i can get the 4.1.10(b) firmware for the SPA 921 Phone?The 5.1.8 firmware doesn`t work after upgrade with our telephone system.Or is it possible to download the firmware from a phone with a tool?

Thanks

Mikel

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards