cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

One-way voice or failed call connections for inbound calls from the PSTN to Cisco CallManager through a Cisco IOS MGCP gateway

3670
Views
0
Helpful
2
Comments

Core Issue

Calls from IP phones towards the gateway or Public Switched Telephone Network (PSTN) work as expected.

Calls from the PSTN towards the IP phones may either fail completely or the user may experience one-way voice. Examination of trace files on Cisco CallManager reveal the gateway router is using a different IP address as the source of the call to what is actually configured on the Cisco CallManager.

 

The gateway router may have subinterfaces configured on the Fast Ethernet to allow traffic to be passed between different VLANs. The gateway router is using the IP address of a different configured subinterface on the Fast Ethernet port even though it may have originally registerd to the Cisco CallManager with a different IP address on another subinterface.

The call either fails completely or experiences one way voice if the source IP address the gateway uses is different to the source address Cisco CallManager is expecting.

Resolution

The gateway can be forced to use a consistent IP address for all Media Gateway Control Protocol (MGCP) signaling and media traffic. In this example, the gateway router uses FastEthernet0/0.1 for the initial registration with the Cisco CallManager and for all subsequent MGCP control and media traffic:

mgcp bind control source-interface FastEthernet0/0.1

mgcp bind media source-interface FastEthernet0/0.1

For more information, refer to  MGCP  Gateway Support for the Bind Command.

For additional information, refer the One-Way Audio or No Audio section of Cisco CallManager Device Issues.

Comments
Community Member

I have 2921 router with MGCP gateway register with Call Manager 8.6. Outgoing calls are working but incoming calls from the PSNT do not work.  I tried using the above solution but no luck so far. Please advise


					
				
			
			
			
				
			
			
			
			
			
			
		

i had the same problem in MGCP so i turned to H323 but i still could make calls from IP phones to outside but couldn't make calls from PSTN to my IP phones ,

i use GSM wireless terminators insted of landlines

my H323 configuratin as next

Building configuration...


Current configuration : 3690 bytes
!
! Last configuration change at 11:44:54 UTC Mon Feb 10 2014
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Bar-VOIPRouter-C2921
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$1R..$VD/ymz9ZO7y9kA7o8GCPi1
enable password o cisco
!
no aaa new-model
!
!
!
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group MOBILE
!
!
trunk group mobile
!
!
trunk group MOBIL
!
!        
!
voice-card 0
dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
h323
!
!
!
!
license udi pid CISCO2921/K9 sn FCZ143771WE
hw-module pvdm 0/0
!
!
!
username admin privilege 15 password 0 ELBARON
!
redundancy
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
!
!
interface GigabitEthernet0/0
ip address 10.10.10.254 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.10.10.254
!
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
!
!
ip default-gateway 10.10.10.1
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash0
!
ip route 10.10.0.0 255.255.0.0 10.10.10.1
!
!
!
!
!
!
tftp-server flash0:SCCP11.8-4-2S.loads
tftp-server flash0:SCCP31.8-4-2S.loads
tftp-server flash0:SCCP41.8-4-2S.loads
tftp-server flash0:SCCP42.8-4-2S.loads
tftp-server flash0:SCCP45.8-4-2S.loads
tftp-server flash0:SCCP70.8-4-2S.loads
tftp-server flash0:SCCP75.8-4-2S.loads
!
control-plane
!
!
!
voice-port 0/0/0
trunk-group MOBIL
supervisory disconnect dualtone mid-call
supervisory answer dualtone
no battery-reversal
echo-cancel coverage 64
cptone EG
timeouts call-disconnect 5
timeouts wait-release 5
timing hookflash-out 500
connection plar opx 1005
impedance complex2
description line_1
caller-id enable
!
voice-port 0/0/1
signal groundStart
echo-cancel coverage 64
timing hookflash-out 50
shutdown
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
!
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
!
!
dial-peer voice 3 pots
description mobile_connection
destination-pattern .T
no digit-strip
port 0/0/0
forward-digits 11
!
dial-peer voice 1 voip
incoming called-number .
!
dial-peer voice 2 voip
incoming called-number .
!
dial-peer voice 4 voip
description PSTN_to_PUB
destination-pattern 1005
session target ipv4:10.10.20.254
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 5 voip
description PSTN_to_SUB
destination-pattern 1005
session target ipv4:10.10.20.253
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 6 pots
incoming called-number .
port 0/0/0
!
!
!
!
gatekeeper
shutdown
!
!        
telephony-service
max-conferences 8 gain -6
transfer-system full-consult
!
!
line con 0
line aux 0
line vty 0 4
password ELBARON
login
!
scheduler allocate 20000 1000
end

your help is very appriciated

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards