cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Troubleshooting CTS codec and phone CUCM registration issues

13216
Views
15
Helpful
0
Comments

A number of issues can cause either a CTS codec or phone to be Unregistered or Rejected in CUCM.

unregistered.png

Basic Configuration

1. Try to ping the CUCM from the codec using "utils network ping". If you know ICMP isn't being blocked on the path and you can't hit it, the first step should be to investigate network or DNS resolution issues.

2. Ensure port 6970 is not blocked. This is required for most telepresence devices to download their configuration file from the CUCM. Phones use UDP port 69 for TFTP.

3. If using DHCP, ensure DHCP option 150 (TFTP) is enabled and includes the IP of the correct TFTP server. On the codec, check Configuration -> Unified CM to ensure the codec is pointed at the correct CUCM. On the phone, check Settings -> Network Configuration -> IPv4 Configuration -> TFTP Server 1.

4. Ensure the correct MAC address is set under the CUCM device profile. For the codec, this can be found in the GUI under Device Information. For the phone, this can be found under Settings -> Model Information.

5. Ensure both the codec and the phone have a Directory Number set, and that it is the same DN.

6. Ensure the access switch is not using the same number for the data and voice VLAN. For example, do not use both "switchport voice vlan 10" and "switchport access vlan 10".

7. If this is a new CUCM install, ensure the Call Manager and TFTP services are running under Unified CM Serviceability.

8. If registration is bouncing, ensure we do not have a duplicate IP address on the network by shutting down your device, then trying to ping the device's IP address.

9. Are the codec sysop logs very sparse in regards to registration messages? In the SIP logs on the codec, do we see a SIP/2.0 404 Not Found that says Warning: 399 cucm_hostname "Database error" ? In previous cases, this issue has been resolved by rebooting CUCM.

10. Are we seeing registration rejected on a new codec/phone or one that refreshed its CTL? Do we see ERROR Config file rejected: signer in the Sysop logs of codec? This could be a CUCM issue where the serial numbers between the CTL installed on the codec and the CUCM CTL are different. To fix this we need to rerun the CTL client from the CUCM.

Codec Specific Issues

1. If we see Registration Rejected on CUCM, and the codec was recently replaced or switched CUCMs, try refreshing the CTL. From the GUI, under Configuration -> Unified CM, try pressing the Delete CTL button. If this works, the button will become grayed out. If it does not, we'll need to delete the CTL from the command line. Log into the CLI and run Adv Mode (case sensitive) followed by utils security clear.

deletectl.png

2. Is the directory number 7000? This means we are in DEMO mode (Non-CCM mode). Verify this in the CLI with show config system. If you see "CCM Mode : NON-CCM", then a step was missed at the factory. Open a TAC case to get this resolved.

3. Are you failing to register to a secure device profile? The step to install the manufacturing installed certificate might have been missed at the factory. Check with the show cert mic command. If it shows there is no installed MIC, open a TAC case to get this resolved via root. You can also factory reset the endpoint to fix this.

4. Do we see Registration Rejected from CUCM or a 485 Ambiguous "Device Type Mismatch" SIP message? There's a good chance the device profile is set to the wrong device type. This is most common with CTS-1300-65s and TX-1300s (or CTS-1300-47). These endpoints use entirely different codecs and must be set correctly. There is no way to change the device type of a profile, the profile will have to be deleted and recreated.

devicetype.png

Alternatively, if all other troubleshooting fails, this might be fixed by setting the cts type manually to avoid this mismatch. Do this with set ctstype [type] from the CLI, where type is the endpoint model number such as 1300 or 3200.

5. Is the registration bouncing between Registered and Unregistered? This could be an issue with the cameras connected to the codec. The codec will not register unless all of the cameras are healthy. Check the GUI, are any of the cameras in error under System Status? If so, try reseating the camera cables at both ends. If the issues persist, open a TAC case and try to isolate the camera problem.

Phone Specific issues

1. Was this phone recently replaced, factory reset or is it a new install running a SCCP phone load but trying to register to a SIP profile? The phone should first be upgraded to SIP 8.4(4) and then to a higher SIP load such as 9.2(3). See this article: https://supportforums.cisco.com/docs/DOC-23041

2. Was this phone replaced did it change CUCMs? Are we seeing Registration Rejected? Delete CTL from the phone by going to Settings -> Security Configuration -> Trust List -> CTL File. Hit * * # on the keypad to unlock the settings, then select Erase. There is no way to do this remotely.

Cisco.com Documentation

Troubleshooting Registration: http://www.cisco.com/en/US/docs/telepresence/cts_admin/cts_troubleshooting/cts_trbl_registration.html

CUCM Configuration for CTS: http://www.cisco.com/en/US/docs/telepresence/cucm_cts/cucm_cts_admin_book/guide/cucm_cts_admin_config.html

DHCP Option 150: http://www.cisco.com/en/US/docs/security/asa/asa72/configuration/guide/dhcp.html#wp1059719

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards