Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

Troubleshooting - IP phone stuck for a while at registering state


Lets troubleshoot IP Phone long time stuck in registering state while CUCM publisher servers is down.

We have IP phone previously configured and was working, but then disconnected for a while. Yesterday we were  going to give this phone to new user, so i change line name on CUCM while phone was offline. We turned off CUCM Publisher server later and while just subscriber server was running IP phone was connected to network and after long time 'registering' it start up with old user name on display.

Not to loose time on guessing what can be issue, what is not configured correctly on server or anywhere else i decided to go directly to method that will give answer to all questions, span IP phone port and see on Wireshark what is happening, what this phone is talking on LAN, what it is waiting for such long time and where it got this old config. meanwhile i can call from phone and i see new assigned line name at other party.


Luckily phone is right on my hand and laptop and phone are connected to the same switch so lets go to the switch (WS-2960L-48PC-LL) and configure port span.

IP Phone is connected to port GigabitEthernet0/18
laptop with Wireshark is connected to port GigabitEthernet0/20

switch configuretion ->
ACC-3#conf ter
ACC-3(config)#monitor session 1 source interface Gi0/18
ACC-3(config)#monitor session 1 destination interface Gi0/20
ACC-3(config)# end


lets verify span port configuration ->
ACC-3#show monitor session 1
Session 1
Type : Local Session
Source Ports :
Both : Gi0/18
Destination Ports : Gi0/20
Encapsulation : Native
Ingress : Disabled

before starting capture i use to disable all protocols except NPCAP packet driver not to have unnecessary protocol traffic originated from laptop meanwhile still to be able to monitor using Wireshark. If we turn off NPCAP on interface we cannot see interface at Wireshark interface list.

pc interface.JPG








Lets see Boot process of IP phone previously connected to Call manager.
From packet capture i saw that after getting ip address over DHCP option 150 (TFTP server ip address option) IP Phone is trying to contact TFTP service on IP . (for a long time approx 7 min) then it loads last configuration it got from server and stored in memory month ago.

Hmm... i have got a question, why IP phone is not trying other CUCM server?

I checked DHCP server IP option 150 and there was just one of CUCM servers IP defined.

dhcp server pool configuration is below ->
ip dhcp pool voice
option 150 ip


hmm.. probably it was a reason why IP Phone is trying only TFTP server and while this server is down it go to long fallback timeout which ends up loading config file from memory.


Now lets fix the reason and try the result
dhcp server pool configuration updated as below->
ip dhcp pool voice
option 150 ip


Reset phone and this time it registered quickly, issue solved.

BUT when i go back to Wireshard to see what happened this time what i saw was something new for me. Phone after trying to reach TFTP for 10 second switched to but not tried to connect to TFTP as i was expecting but sending GET request to which was existed and phone loaded this file. Hmm... nice, so far so interesting, now i have thing to red about next.


Good luck and hope this post was helpful for you.





hello I would like to know how many licenses use the following phone model Cisco 8811 8821,7925,7911, 7961

Dear Alvaromator , we use enhances licenses and models we use (8841, 8865) each phone consumes 1 enhanced license.

let me share quote from license manager

License Description

Enhanced license provides rights to:

  • One device, including all Basic features, plus advanced (voice and video) call control features including desktop and mobile clients.
  • Examples include Cisco 3911, Cisco 3951, Cisco 6941, Cisco 6945, Cisco 6961, Cisco 79xx, Cisco 89xx, Cisco 99xx, Cisco E20, Cisco TelePresence EX60, Cisco TelePresence EX90 and third-party SIP
Content for Community-Ad