Showing results for 
Search instead for 
Did you mean: 

Unable to upload the MoH file in the Cisco CallManager 5.x and the "Unmapped Exception The entity name must immediately follow the '&' in the entity reference" error message displays


Core Issue

When you try to upload the Music on Hold (MoH) wav file through the Cisco CallManager Adminstration page > Media Resource > MOH Audio file Management, and upload a file that is 37 MB in size , it is unable to upload the file and shows this error message:

unmapped Exception the Entity name must immediately follow the '&' in the entity reference. HTTP 500 No space left on Device.

When you attempt to create a remote support user under the Cisco CallManager OS administration page, it shows the Error : HTTP Status 500 - Type Exception report. Description : The server encountered an internal error () that prevented it from fulfilling this request error message.


This issue is documented in Cisco bug ID CSCsh57225. One possible workaround for this issue is mentioned in these steps:

  1. Create a wav file 16-bit PCM with same exact name as the original bad wav file. If desired, you can copy or rename a known good MoH wav file as same name as the bad file.
  2. Choose MOH Audio Source web admin and import this replacement as the good wav file.
  3. This should remove the & problem and create a good xml file.  

These previously mentioned steps should resolve the issue with MoH.

This issue is also resolved if you install the engineering specials on the Cisco CallManager versions installed. It is fixed in these verions:

  • 5.0(4.2128.001)
  • 5.1(1.2106.001)
  • 5.1(1.9131.026)

Open a case with Cisco Technical Support with the TAC Service Request Tool in order to obtain an appropriate Enterprise Special patch.


I just ran into this bug during a upgrade to 10.5.1.  The customer had never updated any MOH files since 2007.  So after our upgrade, the error manifested while we tried to add new files.


The fix, courtesy of a TAC case and some work arounds is the following.


From CLI:

file view activelog mohprep/CiscoMOHSourceReport.xml

within the file you will see each of your MOH files listed, and following each will be an <error>0</error> 

If you any of your files listed with something other than 0, that is the one that is throwing the exception.  Look for file names with un-supported characters as tip off.

The fix is to remove the offending "music" xml file from the directory.  You don't need to remove the wav files, just the xml file matching the name.

from cli:

file delete activelog mohprep/filename.xml

You can no restart the ip media streaming service to see if that clears the error.  On my issue we had to also remove the CiscoMOHSourceReport.xml file.  Restart the streaming service again.  And then to upload a new MOH file.  When the file is uploaded it forces the server to recreate the CiscoMOHSourceReport.xml file, by reading each of the individual xml files. 


That fixed it for me, so I thought I'd share. 

Recognize Your Peers
Content for Community-Ad