cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1102
Views
0
Helpful
1
Replies
Beginner

cannot see routes from same customer different site - LAB environment

Hello Cisco Community, 

 

NOTE: The R1-PE will use routing protocol OSPF on Customer ACME1 and EIGRP with Customer CBT1 in contrast R5-PE will use RIP with ACME2 and BGP with CBT2

 

Attached the lab environment 

 

The configuration for each router is below, except the Provider Routers. the issue is the CBT1 & CBT2 is the same customer different site but i cannot see the routes which they advertise on PE routers so to have end to end connectivity between the Customer. 

 

 

 

CE Router -  ACME1 

 

interface Loopback0
ip address 172.16.111.2 255.255.255.255
!
interface Serial0/0
description === PE ===
ip address 172.16.101.2 255.255.255.252
clock rate 64000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
-----------------------------------------------------------------------------

CE Router - CBT1

 

interface Loopback0
ip address 172.16.222.2 255.255.255.255
!
interface Serial0/1
description === PE ===
ip address 172.16.101.2 255.255.255.252
clock rate 64000


router eigrp 102
network 0.0.0.0
no auto-summary

 

---------------------------------------------------------------

 CE Router - ACME2

 

interface Loopback0
ip address 192.168.111.2 255.255.255.255

 

interface Serial0/0
description === PE ===
ip address 192.168.202.2 255.255.255.252
clock rate 64000
!

router rip
version 2
network 0.0.0.0
no auto-summary

 

------------------------------------------------------------------------

 

CE router - CBT2 

 

interface Loopback0
ip address 192.168.222.2 255.255.255.255
!
interface Serial0/1
description === PE ===
ip address 192.168.202.2 255.255.255.252
clock rate 64000
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 192.168.202.1 remote-as 13979
no auto-summary

 

-----------------------------------------------------------------

 

Provider Edge Router - R1-PE 

 

!
ip vrf ACME1
rd 65000:13979
route-target export 65000:1
route-target import 65000:1
!
ip vrf CBT1
rd 65001:13979
route-target export 65001:1
route-target import 65001:1

mpls label range 100 199

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
description === R2-P ===
ip address 10.14.0.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
description === ACME 1 ===
mac-address 0000.1111.1111
ip vrf forwarding ACME1
ip address 172.16.101.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1
description === CBT 1 ===
mac-address 0000.1111.1111
ip vrf forwarding CBT1
ip address 172.16.101.1 255.255.255.252
clock rate 2000000
!
router eigrp 1
auto-summary
!
address-family ipv4 vrf CBT1
redistribute bgp 13979 metric 1 1 1 1 1
network 172.16.0.0
auto-summary
autonomous-system 102
exit-address-family
!
router ospf 101 vrf ACME1
log-adjacency-changes
redistribute bgp 13979 subnets
network 172.16.101.1 0.0.0.0 area 0
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.14.0.0 0.0.0.255 area 0
!
router bgp 13979
no synchronization
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 13979
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community extended
exit-address-family
!
address-family ipv4 vrf CBT1
redistribute eigrp 102
no synchronization
exit-address-family
!
address-family ipv4 vrf ACME1
redistribute ospf 101 vrf ACME1
no synchronization
exit-address-family
!

-------------------------------------------------------------------

 

Provider Edge Router - R5-PE

 

!
ip vrf ACME2
rd 65000:13979
route-target export 65000:2
route-target import 65000:2
!
ip vrf CBT2
rd 65001:13979
route-target export 65001:2
route-target import 65001:2
!
mpls label range 500 599
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
description === R4-P ===
ip address 10.45.0.5 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface Serial0/0
description === ACME 2 ===
mac-address 0000.5555.5555
ip vrf forwarding ACME2
ip address 192.168.202.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1
description === CBT 2 ===
mac-address 0000.5555.5555
ip vrf forwarding CBT2
ip address 192.168.202.1 255.255.255.252
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 10.45.0.0 0.0.0.255 area 0
!
router rip
version 2
!
address-family ipv4 vrf ACME2
redistribute bgp 13979 metric 5
network 192.168.202.0
no auto-summary
exit-address-family
!
router bgp 13979
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 13979
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
neighbor 1.1.1.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CBT2
neighbor 192.168.202.2 remote-as 65001
neighbor 192.168.202.2 activate
no synchronization
exit-address-family
!
address-family ipv4 vrf ACME2
redistribute rip
no synchronization
exit-address-family
!

 

Thank you in advance.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: cannot see routes from same customer different site - LAB environment

SOLVED 

1 REPLY 1
Highlighted
Beginner

Re: cannot see routes from same customer different site - LAB environment

SOLVED 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards
This widget could not be displayed.