cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
6213
Views
0
Helpful
7
Replies
Chris7
Beginner

ABNORMALLY ENDING - SIP code [200], Reason Hdr [Q.850;cause=38]

Hello,

I configured all environment (CUCM, ICM packaged and CVP), but calls to the CVP not work. The settings are as installation guide packaged cce and file audios in the correct format. PG is active and CVP services works. In ICM script calls are failed in send to vru node. When call for Route Pattern is muted for 10 seconds and then is disconnected, the display show "reorder".

Here's what the error in CVP:

1204: 10.120.6.75: Jun 19 2013 17:14:44.078 -0300: %CVP_9_0_SIP-3-SIP_CALL_ERROR:  CALLGUID = 1D124E8000010000000000D84606780A LEGID = 1d124e80-1c21119a-1f3-4606780a - [INBOUND] - ABNORMALLY ENDING - SIP code [200], Reason Hdr [Q.850;cause=38] Q850 Reason [38 - Network out of order, typically a TCL script abnormal disconnect.], GW call using SURV TCL flag [false], NON NORMAL flag [true], DNIS [7065], ANI [1004] with AGE (msecs) 4500 and Call History : 77711110001215|-1; [id:5004]

Now I see that the audios are not loaded in GW, I formatted the flash and transfer files from the CVP to the gw ok, but cant make the audio-prompt load command.

CUCM - System version: 8.6.2.21900-5

CVP - Version: 9.0(1)

Unified CCE Version9.0.2.0.0.1454

Cisco IOS Software, 2800 Software (C2800NM-IPVOICEK9-M), Version 15.1(4)M3, RELEASE SOFTWARE (fc1)

Any help would be appreciated.

Cris

1 ACCEPTED SOLUTION

Accepted Solutions

Hey did you notice this, Can you check in your script do you miss "//"

user.microapp.media_server: http:10.120.6.75:7000/CVP,     user.media.id: F061440000010000000000DF4606780A,, LEGID = , DNIS = 77711110001222, ANI = sip:1004@10.120.6.75:5060 

Additionally in the gateway i see like this, Is this right ?

http://http:10.120.6.75:7000/CVP/en-us/application=CimporNovo;callid=F061440000010000000000DF4606780A/pgravada.wav

I dont understand why the Application name =CimporNovo is included in PM Script. (nothing stays in top of my mind as of now for this)

Can you check those things and test again.

Regards,

Senthil

Rate if this helps

View solution in original post

7 REPLIES 7
Senthil Kumar Sankar
Cisco Employee

Cris,

Can you attach the complete Call Server Logs

Regards,

Senthil

Hi Senthil

Attached the Gateway debug & CVP logs.

Thanks

Cris

Hey did you notice this, Can you check in your script do you miss "//"

user.microapp.media_server: http:10.120.6.75:7000/CVP,     user.media.id: F061440000010000000000DF4606780A,, LEGID = , DNIS = 77711110001222, ANI = sip:1004@10.120.6.75:5060 

Additionally in the gateway i see like this, Is this right ?

http://http:10.120.6.75:7000/CVP/en-us/application=CimporNovo;callid=F061440000010000000000DF4606780A/pgravada.wav

I dont understand why the Application name =CimporNovo is included in PM Script. (nothing stays in top of my mind as of now for this)

Can you check those things and test again.

Regards,

Senthil

Rate if this helps

View solution in original post

Hi Senthil


Thanks for your reply, very good! I changed these scripts several times and made this mistake, I put the "//". I will review the network vru script to see if there is some wrong. Now some audios play ok, but the call not arrive to the agent yet.

Cris

Senthil

I found the problem, the ATR configuration was wrong, I setup the correct extension number agents and now it works fine.

Thank you

Cris

Hi Senthil,

Now, the calls are routed by the ICM Script, ok, but when arrives skill node, the call is disconnected, strange. I listen the error message from CUCM. This the original problem since I installed the lab:

4606780a - [INBOUND] - DIALOGUE_FAILURE from ICM Router sends 404 rejection to call. errorcode=15 [id:5004]

986: 10.120.6.75: Jun 20 2013 23:05:25.484 -0300: %CVP_9_0_SIP-3-SIP_CALL_ERROR:  CALLGUID = 46AFA080000100000000001D4606780A LEGID = 46afa080-1c31b54e-28-4606780a - [INBOUND] - ABNORMALLY ENDING - SIP code [404], Reason Hdr [SIP;cause=404] Not Found, GW call using SURV TCL flag [false], NON NORMAL flag [true], DNIS [7060], ANI [1004] with AGE (msecs) 7625 and Call History : 77711110001027|-1; [id:5004]

995: 10.120.6.75: Jun 20 2013 23:05:25.484 -0300: %CVP_9_0_SIP-3-SIP_CALL_ERROR:  CALLGUID = 46AFA080000100000000001D4606780A LEGID = 46afa080-1c31b54e-28-4606780a - [INBOUND] - ABNORMALLY ENDING - SIP code [404], Reason Hdr [SIP;cause=404] Not Found, GW call using SURV TCL flag [false], NON NORMAL flag [true], DNIS [7060], ANI [1004] with AGE (msecs) 7625 and Call History : 77711110001027|-1; [id:5004]

You will help me a lot if you know this problem.

Thanks

Cris

Chris,

Have you configured Static route in CVP (SIP Tab) pointing to Call Manager for Agent transfer.

Regards

Sathya.

Content for Community-Ad

Spotlight Awards 2021