cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
830
Views
10
Helpful
4
Replies

Accessing QM recordings from downed QM 8.5 server

Christian Legg
Level 1
Level 1

Hello Folks,

 

In days gone by we ran Cisco UCCX 8/5 with Calabrio's Cisco-branded QM system to record calls.  Some time ago, the system was switched off, and our networks have changed and licenses have expired, so we can't spin the system back up again.

 

I do have access to the QM database and the .SPX filestore for the calls - all 4 million of them - and can track down any call that I want without problems.

 

BUT...

 

When I get to the actual SPEEX format file that the database leads me to it is unplayable in any SPEEX player that I have been able to find.  I suspect that the file itself is encrypted to ensure that it can only be played back through the QM interface and system, which makes sense as it was a fully audited system.  But we can no longer use the core QM system to get at these calls due to licensing being IP network specific and our specific IP networks being long gone and unfortunately not replaceable.

 

Has anyone had any success recovering calls from long forgotten QM systems?  We're tapping a few personal contacts within Cisco as our QM system is far from being actively licensed and we have no TAC support available since the business decided to move from Cisco to a competitor's product.

 

Any thought or ideas would be appreciated.

 

thanks in advance

 

Christian

4 Replies 4

Anthony Holloway
Cisco Employee
Cisco Employee
A problem I hope you encounter, and really, it's not just you, but anyone in the same position, is the burden to prove you own those call recordings, and the right to listen to them. I mean that in the nicest way possible.

Good luck with your adventure Christian, and hopefully you can recover your data.

For the readers, let this be a lesson: don't decomm a server responsible for millions of records of data, before you can confirm the data will be usable outside of said server first.

Graham Old
Level 7
Level 7

The files on disk are encrypted so the only way to play them back is via the web interface. To login to the web interface you need a licensed user.

I would think your only other way of getting them is to use the Calabrio Recording Export Utility CRX

You download it from the base server

http://<Calabrio IP>/TUP/QM/Administrator.htm

The single threaded version does not need a license.

See the attached Reference Guide for how to set it up.

I would think this has a good chance of working. It would be useful if you could report back.

Graham

Christian Legg
Level 1
Level 1

Hey folks - I got this issued solved and thought that my solution may help others.

 

Key to the solution was finding a way to have the server think it was still talking to itself via its old IP address on a network that we no longer run, as well as then be able to talk to an AD server - at least long enough to be able to reconfigure IP addresses.

 

First off, I booted the server with a new IP address and got it talking with AD on our domain.  Of course, this gives lots of errors when running postinstall as the server can't find itself at its old IP address, even when I specified the new base server IP addresses info when staring postinstall.exe.

 

So, I created a loopback adaptor and gave it the IP address that the system used to have and lo - everything in postinstall.exe worked - at least bits that were not connecting to UCCX or CM as they were still down.  Looks like this was key - in doing this the various bits of the server can talk to themselves again.

 

This gave enough connectivity to the QM services to allow me to flick the QM authentication from UCCX to Active Directory under "Enterprise Services".  A little bit of LDAP debugging was required to get the syntax right - it's not clear from the documentation that the base OU details you provide at the top of the screen apply to all following entries, both search scopes and (importantly) LDAP lookup user credentials.

 

And of course before all of this, I had reloaded the SQMDB onto another SQL server so that when postinstall did start I could easily point it at the instance.

 

All that was then left to do was run the gauntlet that is outdated and unsupported Java versions running code with expired security certificates inside IE (locked down) on a Windows 2008 R2 server (our QM host) and lo we have the interface that is so bad that even its mother abandoned it.

 

And from there, it's a simple matter to locate and export calls for your listening enjoyment.

 

Thanks for those who provided their input, and I hope that this may help anyone else who inherits a similarly mothballed QM system.

Thank you for posting back your journey and solution! I'm glad it all worked out for you in the end.