cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1682
Views
2
Helpful
14
Replies
Highlighted
Beginner

Agent Desktop 10.5 - Stealing Focus

Is anyone able to tell me how to STOP Agent Desktop from stealing focus when a call comes in?

 

Thank you. 

14 REPLIES 14
Highlighted
Beginner

In reference to the Cisco

In reference to the Cisco Desktop administrator document , from the Cisco desktop admin ( software ) choose your required option under the miscellaneous tab ( check attached screenshot )

 

Please let me know if it is helpful by rating.

 

Regards,

Hussein

Highlighted
Enthusiast

Completely NOT helpful.  

Completely NOT helpful.   None of those options seem to consistently prevent CAD from taking focus from other applications when call comes in.  It this possible or not?

Highlighted
Participant

This discussion has been

This discussion has been reposted from Additional Communities to the Contact Center community.

Highlighted
Beginner

Suggestion does not help.

Suggestion does not help. Focus still goes to agent desktop.

Highlighted
Beginner

I am having the same problem

I am having the same problem but not at all workstations. I've only been able to replicate the problem on virtual users using Citrix desktops. Physical PCs I have not been able to replicate the issue.

What type of users do you have?

Highlighted
Beginner

Thanks Sokka, Our environment

Thanks Sokka,

 

Our environment only has it installed on laptops.

Highlighted
Beginner

Have you looked into this

Have you looked into this registry setting in windows? ForegroundLockTimeout

 

I've been playing with it but getting inconsistent results.

 

EDIT: It is in 3 places in my registry in Windows 7.

Highlighted
Beginner

I started looking at that,

I started looking at that, but from what I read it sounded like that doesn't work very well with Windows 7.

 

Have you had any success?

 

I would peruse that if it works out, but it's frustrating that Agent Desktop appears to just be designed this way.

Highlighted
Beginner

I've only done brief testing.

I've only done brief testing. I had physical Windows 7 PC that all 3 ForegroundLockTimeout registry keys were set to default decimal value of 200000. CAD was not stealing focus.

I modified all 3 registry keys to 0 and rebooted. CAD was now stealing focus. I thought I had the solution so I modified all 3 registry keys back to default of decimal 200000 and rebooted. On reboot, CAD still steals focus when call is presented.

I'm not sure if I have something in my Windows environment affecting this but the registry keys do appear to still have an effect.

Highlighted
Beginner

I have also had this problem

I have also had this problem since upgrading from 7 to 10.5 of UCCX.  I opened a case with TAC, escalated, captured logs, etc.  NO SUCCESS.   This apparent change in functionality is incredibly disruptive to all agents and they complain to me constantly, they want it back to the way it was.  It worked consistently and perfectly in UCCX 3.5 and 7.x....   something did change...  Cisco TAC could not reproduce the problem and closed the case without resolution.

 

If anyone knows how to consistently prevent the CAD from stealing focus when a call comes in, please share.  We have tried all combinations of settings (to the best of our knowledge), but nothing is working.

 

Has anyone upgraded to 10.6 and seen the problem go away??  That was my next plan of attack.

Highlighted
Beginner

I am using UCCE so I don't

I am using UCCE so I don't know about UCCX. The result of my case with TAC was the following,

The intended behavior from version 7.5 through 10.01 is to steal focus. In the past there have been bugs where CAD was not stealing focus. Some of these bugs have been patched in 10.01 so in most cases CAD will steal focus.

Highlighted
Beginner

We've been having the same

We've been having the same problem with UCCX 8.5 for the past couple of weeks. CAD steals/regains focus when a calls comes in through the queue, thus stopping any typing in its tracks. No change was made on the UCCX side. Operators are using Windows 7 Pro physical workstations. Desktop Admin settings already has Preferences set to "Agent Choice" for the environment and Desktop Agents have "Stealth" set locally at each workstation.  I first thought that an upgrade my fix this, but it seems that even newer versions may have the same issue.  Has anyone run into any new recommendations?

Also, I've tried setting the Stealth mode globally in the Admin console, taking away the operator's option to choose.  I had the operator reboot the computer, but still had the focus problem. . . strange.

Highlighted

I'm on Cisco Agent Desktop 10

I'm on Cisco Agent Desktop 10.6 and have this issue.

It is extremely annoying.

Please provide a check-box in the app to disable this behavior.

Highlighted
Beginner

The CAD preferences have to

The CAD preferences have to be set to Stealth Mode, either on the local client or globally from Desktop Supervisor. Then, after the agent logs in and is ready, the CAD window must be minimized, at which point it will only show up as a task bar notification icon.  It will only pop back up when the user double-clicks on that icon.

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey