cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6187
Views
5
Helpful
7
Replies
Highlighted
Explorer

Agent not showing up in Supervisor desktop

I have a supervisor with a single team. Team includes 3 agents. When supervisor and a three agents are logged into CAD, 2 team members appear in Supervisor desktop but not the third. When a call comes into the main line, the call will successfully route to all three of the agents. Here are a few differences I've noted. 1) When looking at the main CAD window, there's a description column which, for two of the agents, is their first and last name. For the agent that isn't showing up, his description is "Extension: xxxx". Also, if you bring up the chat window on agent #3 it indicates that there are no other members in chat. When you bring up the chat window on the supervisor desktop or on the other two agent's CAD, they all show up (expect for agent #3). When I do a netstat from agent #3's PC, I can see connections to the chat server (59000) and the PC is listening on port 59020 and looks to have an established connection from the server. All PCs in this group are running Windows XP SP2 and none of them have the firewall enabled.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Yes. You must add that user to the same team. Once you do you must close both the Agent Desktop off that user and the Supervisor desktop from the supervisor. Then reopen the applications and you should see the user in there.

To check and make sure what team their in you can either open Cisco Desktop Administrator and go under Personnel Configuration and click Agents then find the agent and verify the team is the same as the other 2.

Or you can log into the IPCC web admin page and go to SubSystems -> RmCm then click on Resources and verify the team on the right. Make sure it matches the other 2 that are showing up.

View solution in original post

7 REPLIES 7
Highlighted
Frequent Contributor

Hi,

Check to see if any firewall installed in this agent PC,

Also please confirm the existance of this problem in case the agent try another PC

Best Regards

Highlighted
Explorer

Did you check the Cisco Desktop Administrator and verify that the agent shows up in the same Team?

Highlighted

Yes. You must add that user to the same team. Once you do you must close both the Agent Desktop off that user and the Supervisor desktop from the supervisor. Then reopen the applications and you should see the user in there.

To check and make sure what team their in you can either open Cisco Desktop Administrator and go under Personnel Configuration and click Agents then find the agent and verify the team is the same as the other 2.

Or you can log into the IPCC web admin page and go to SubSystems -> RmCm then click on Resources and verify the team on the right. Make sure it matches the other 2 that are showing up.

View solution in original post

Highlighted

Thanks for the help. Here's what I did to resolve the issue. Once I finally got access to the Desktop Administrator program, I saw that the missing agent did not appear in the team. This was different than what I was seeing in the application admin web page. In the application admin web page, the agent was in the team. I removed and then re-added the agent in the application admin web page and the agent instantly showed up in the team with the Desktop Administration program. I then asked the agent to restart CAD and everything was great after that.

Highlighted

Hi,

I have the same problem and I already tried to remove the agent and re-create it and reinstall CAD but nothing helped. first day when I do that, everything works fine, but then after agent and supervisor are logged out and logged in again, agent is not able to chat and supervisor didn't see that agent.

everything was working just fine and then I was testing something and move that agent from one CSQ (and Team) in the other (the testing ones). After the test, I moved the agent back to the appropriate CSQ and Team. After that, this problem occurred.

Do you have any idea what could be the problem. First thing that cross my mind is that supervisor was logged in all the time so maybe to log out supervisor, uninstall CAD and remove the agent. After that to recreate the agent again, assign it the right CSQ and Team, reinstall CAD and after that to log in supervisor and agent.

Also I noticed that connections to the ports 59003 and 49555 are not active on this agent but on the agent that is working fine connections to these ports are active.

Thx,

Jelena

Highlighted
Beginner

***ALTERNATIVE SOLUTION***

I fixed this same problem by restarting 3 services that Supervisor Desktop relies heavily on. This may work for you too. Do this after hours.

 

  • Cisco Desktop Recording and Statistics Service
  • Cisco Desktop Enterprise Service
  • Cisco Desktop Call/Chat Service

This should be done on both Master and Slave starting with the current Master Node.

 

Highlighted

Hi

I have problems with the Cisco Supervisor desktop and Cisco Agent Desktop

I have 1 supervisor and 3 agents using CAD, the supervisor sees all the agents registered, but from one moment to the next there are agents that disappear from the supervisor's registry, (it is not displayed in the software of the supervisor) and has no control of the agent , I think that the agent will have retired or closed session, but the agent appears active, but after a few minutes it appears in the software

Any idea of what may be happening. this happens with any of the agents we have, it appears and disappears from the Supervisor desktop software.

 

Regards ,

Carlos P.

Content for Community-Ad