cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

AMA-CUCM Troubleshooting: Best Practices for Reading Trace Files

554
Views
10
Helpful
7
Replies
Beginner

AQM 9.0.1 error

Hi experts,

After I upgrade AQM to version 9.0.1  SR4 i get the following error during the post install:

The following database error ocurred:

Schema program failed: The index 'Ccr_evaStateFK_personFK_evaluatorFK_localStartime_Covering_Index' is dependent on column 'icmCallId'

I have windows 2008 standard

SQL 2008 standard

CUCM 8.6.2a

UCCX 9.0

Anyone knows what can be happening?

Thanks in advance!!

7 REPLIES 7

AQM 9.0.1 error

Hi

I've seen issues similar (but not quite the same) as this one - what version are you upgrading from?

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Beginner

AQM 9.0.1 error

From version 8.5 SR2 to 9.0.1 SR4, i didnt find the answer yet...

AQM 9.0.1 error

Hello,

Did you find a fix for the issue,we are facing this issue ditto !!!

Upgrade from AQM 8.5 SR2 to 9.0.1 SR4

CCX : 9.x

CM : 9.1

Appreciate any help

Mathew

Participant

Did you contact Calabrio?

Did you contact Calabrio?

Highlighted
Beginner

Anyone find a fix yet?  I ran

Anyone find a fix yet?  I ran into this last week during our upgrade.

Hello Rob,This issue normally

Hello Rob,

This issue normally occurs when there is an agent or team that has been changed and the database did not recognize the change. 

I would suggest you to raise a case with PDI Calibrio support and get the database fixed.

Mathew

Beginner

Here is what Calabrio sent me

Here is what Calabrio sent me and fixed this issue for me. 

Here is the initial query to run on your SQMDB database once you run into that error message: 

IF EXISTS (SELECT * FROM sys.indexes WHERE object_id = OBJECT_ID(N'[dbo].[Ccr]') AND name = N'Ccr_evalStateFK_personFK_evaluatorFK_localStartTime_Covering_Index') 
DROP INDEX [Ccr_evalStateFK_personFK_evaluatorFK_localStartTime_Covering_Index] ON [dbo].[Ccr] WITH ( ONLINE = OFF )

At that point you may see this error (I did):
Agent_personFK_deactivated_id_activated' already exists on table 'Agent'

If you do, run this query:
IF EXISTS (SELECT * FROM sys.indexes WHERE object_id = OBJECT_ID(N'[dbo].[Agent]') AND name = N'Agent_personFK_deactivated_id_activated') 
DROP INDEX [Agent_personFK_deactivated_id_activated] ON [dbo].[Agent] WITH ( ONLINE = OFF )

At that point, you should be able to complete Post Install.

 

Apparently this is a knows bug/issue that doesn't seem to be published anywhere.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards