cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
546
Views
0
Helpful
2
Replies
Highlighted
Beginner

Audio Barge in not working as expected.

Hello

   Test deployed to CVP-11

   Using an audio element to play an audio file that is 45 seconds long of instructional information, and the barge in option is checked.

    Once the audio completes, or is barged in upon the next element is a form playing a TTS prompt with recognition.

    During the playing of the 45 second audio I try to barge-in  (using speech, and DTMF) but the audio continues to play.

    I was under the impression that CVP would detect the barge in attempt during the 45 second audio causing the audio stream to stop, but I'm not seeing this behavior.

    Appreciate any details of how barge in support should work with the playing of an audio file.

Thanks

Configuration content for the audio play::  (Barge in is not detected)

<?xml version="1.0" encoding="UTF-8" standalone="no"?>

<!DOCTYPE configuration SYSTEM "../../../../dtds/VoiceElementConfiguration.dtd">

<configuration class="com.audium.server.voiceElement.audio.MAudio" serial="0000">

<audio_group bargein="true" count="1" name="initial_audio_group">

<audio name="audio item 1" src="/CVP/audio/TEST/TEST-5-Greeting.wav" use_default_path="true"/>

</audio_group>

</configuration>

2 REPLIES 2
Cisco Employee

Re: Audio Barge in not working as expected.

Looks a conf error to me, did you restarted the VXML Server or redeployed the app after modifications ?

Please check the gateway logs by enabling debug logs and see if the barge in is enabled for the element.

Rising star

Re: Audio Barge in not working as expected.

Are you coming upon this bug? It was relayed to me by a former student - that having the VoiceXML Property named

fetchaudio configured in the Root Doc causes barge-in to be ignored in Audio elements! The workaround would be to configure the fetchaudio in the Settings tab of audio element immediately prior to a web service (or other slow processes).

fetchaudio seems to be the culprit in disabling bargein when an Audio block is played outside of a Form, despite Bargein being set to true in Audio and Form.  This behaviour is consistent across all permutations of Cisco Audio/Form and our Extended Audio/Form.  In essence, Nuance is not receiving the instruction from Cisco to Bargein.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards