cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
743
Views
4
Helpful
4
Replies

Bad fetch in Record element

Malik Ehtasham
Beginner
Beginner

I have a simple application and i have used record element in it. I am facing error.badfetch on that record element. All of other application is working fine. I am using record element first time that's why i am not able to find the error, here is the configuration of the record element.

5s

3

true

true

true

180s

test

wav

wav

C:\temp\

i am not using FTP related configuration. I can hear the prompt which is associated with that element and once the prompt finish it says
"I am sorry we are facing difficulty please callback some letter time "

Here is the error logs

Record_01,enter,

192.168.200.182.1394543043609.0.HelloWorld,03/11/2014 18:04:11.691,Record_01,interaction,audio_group,initial_audio_group

192.168.200.182.1394543043609.0.HelloWorld,03/11/2014 18:04:17.156,Record_01,element,error,error.badfetch

192.168.200.182.1394543043609.0.HelloWorld,03/11/2014 18:04:17.156,Record_01,exit,

192.168.200.182.1394543043609.0.HelloWorld,03/11/2014 18:04:11.691,Record_01,interaction,audio_group,initial_audio_group

Can any body help me

1 ACCEPTED SOLUTION

Accepted Solutions

janinegraves
Rising star
Rising star

Someone a year ago had a corrupt beep.wav on their gateway.

As a quick workaround, try changing the Setting named Start with a Beep

to false.

There are a few gateway configuration settings you need for Recording.

You have to set no vad on the gateway dial peer for calls destined for

recording.

Try these things, if they don't help then let us know.

View solution in original post

4 REPLIES 4

janinegraves
Rising star
Rising star

Someone a year ago had a corrupt beep.wav on their gateway.

As a quick workaround, try changing the Setting named Start with a Beep

to false.

There are a few gateway configuration settings you need for Recording.

You have to set no vad on the gateway dial peer for calls destined for

recording.

Try these things, if they don't help then let us know.

In addition to Janine's suggestions, I would suggest ensuring that whichever dial-peer on your gateway initiates "service bootstrap" has a setting of "codec g711ulaw" (or g711alaw if you use that), instead of using a "voice-class codec" - it needs to be hard-coded to a single codec in order to do any recording.

-Jameson

Malik Ehtasham
Beginner
Beginner

Thanks Janine and Jameson for your quick response. It really save my life, after configuring dial peer i am successfully able to record the audio from the customer... Thumbs up for you guys.(y)

Glad that worked for you, Malik.

Don't forget to mark this discussion as "Answered" on Cisco Communities.

-Jameson
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: