cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
248
Views
0
Helpful
1
Replies
Highlighted
Beginner

Call Studio 12.5 Execution Environments have no Compatible JREs

I have done a fresh install of Call Studio 12.5(1). 

 

Under Window -> Preferences -> Java -> Installed JRE's.  There is the usual eclipse Standard VM that has always been there under previous versions.  However, under Window -> Preferences -> Java -> Installed JRE's -> Execution Environments, none of the Execution Environments have a Compatible JRE.

 

Has anyone else with substantial custom elements encountered this when upgrading to 12.0 or 12.5?

 

Thanks,

Shaun 

1 REPLY 1
Highlighted
Rising star

I did notice this.
And I think Cisco's response to this was that while Studio 12.5 can display and the debugger can run things compiled with java 1.8, the very old Eclipse version can't be used to compile java with the 1.8 jre. So they recommended to use a different java editor (not Studio's eclipse) to create and compile your custom java.
But I haven't really tested it further than that.