cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
585
Views
20
Helpful
15
Replies
lanou
Enthusiast

Call Studio Web Service Element

Dears,

We're trying to use the web service element in a CVP script.

We're able to load the WSDL successfully and to configure the request. However, when configuring the response, we cannot see all the fields noting that the WSDL opens successfully in the browser.

any ideas what could be still missing?

Thanks in advance for your help.

2 ACCEPTED SOLUTIONS

Accepted Solutions

I've heard of this before.

 

To expand it, position your cursor on GetIvrAuthResult and use the arrow keys on your keyboard. If you press the right-arrow, it should expand. The left arrow will collaps it.

 

If that doesn't work, position your cursor just to the left of GetIvrAuthResult (between the triangle and the word  GetIvrAuthResult) and wiggle your cursor slowly until that triangle turns blue - at that moment you should be able to click it to expand.

 

 

View solution in original post

First right-click on GetIvrAuthResult and select Add.   
Then click on GetIvrAuhResult and use the right-arrow key to expand.
Continue to right-click on anything that's gray that you'd like to enable, then arrow on anything that can be expanded.

See screen shots:

 

rightclick.PNG

ThenArrow.png

View solution in original post

15 REPLIES 15
bill.king1
VIP Collaborator

Can you post screenshots of what you mean, like from the Response configuration section? If you load the WSDL and can configure the request, you should be able to configure the response using the standard element.

If the return values are too complex, you may have to select the
checkbox for Save the Full Response
Then you can use the next Audio element to add it to the Activity Log
(to ensure you got it) {Data.Element.WebServices_01.response_xml}
You'll have to key in the variable named response_xml


If you're getting it back, then you can use the SetValue element to
parse the XML using XPath expressions and XpathUtil.eval (See CVP Users
guide)


Hello Bill,

Please find attached screenshots of the Web Service element configuration and note that we're not getting the full repsonse (We cannot expand the response).

bill.king1
VIP Collaborator

Are you sure that you can't expand it? Typically if the GUI shows that expansion box, you can, but it can be finicky to click on it. Are there a number of different response fields you're expecting or only a few?

If it doesn't expand for you, as a test I would see if you could use the WSDL as a file and see if it behaves any better for you (i.e. download it from that site and then load it into Studio and see how it behaves).

Can you post the wsdl (remove any private info) - I can try loading into
my Studio and see if I can get it to display.

Hi Janine,

Please check the attached files.

First right-click on GetIvrAuthResult and select Add.   
Then click on GetIvrAuhResult and use the right-arrow key to expand.
Continue to right-click on anything that's gray that you'd like to enable, then arrow on anything that can be expanded.

See screen shots:

 

rightclick.PNG

ThenArrow.png

View solution in original post

Here's one more screen shot...

result.png

Hello Bill,

Just to let you know, we have installed a new call studio and we migrated all the scripts and we faced the issue on the new server.

On the old Studio Server the wsdl is loaded successfully and we have the full response as you can see in the attached screenshots (1.png & 2.png).

What is weird is that we also tried to load the same wsdl on the old server but we didn't get the full response (3.png).

I've heard of this before.

 

To expand it, position your cursor on GetIvrAuthResult and use the arrow keys on your keyboard. If you press the right-arrow, it should expand. The left arrow will collaps it.

 

If that doesn't work, position your cursor just to the left of GetIvrAuthResult (between the triangle and the word  GetIvrAuthResult) and wiggle your cursor slowly until that triangle turns blue - at that moment you should be able to click it to expand.

 

 

View solution in original post

Hello Janine,

I will try what you suggested and update you.

Thanks

bill.king1
VIP Collaborator

I would double check like Janine said that it isn't just a small GUI type issue.

Also, you mention server. Studio, while it may work, isn't documented as working with server in the compatibility guides, it is documented as working with Windows 10, so that may be coming into play as well.

Not saying it won't work, but that might be part of the issue.

Hello Bill,

Sorry for the typo, it is installed on a Windows10 VM and not on a Windows Server.

bill.king1
VIP Collaborator

Hi @lanou , how did you make out, did it work for you, were you able to expand it?

Create
Recognize Your Peers
Content for Community-Ad