cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Calls are failing as soon as Agent pick the call

manish.raikwar1
Beginner
Beginner

Hi,

I am new in UCCE and recently i have setup UCCE lab, when i am trying to make calls from Ingress gateway calls are getting disconnecting as soon as Agent pick the call. Also i have checked in CVP logs, i can see below error :

 

1562: 10.1.13.21: May 08 2021 18:28:17.972 -0500: %CVP_11_6_SIP-3-SIP_CALL_ERROR: CALLGUID = F1CeUJufR3xMaHQpVRTxnFdsmAa8EgdJ24D LEGID = F388AC07-7ACC11DA-8204A3FF-936FEC4D - [INBOUND] - ABNORMALLY ENDING - SIP code [503], Reason Hdr [SIP;cause=503] Service Unavailable, GW call using SURV TCL flag [false], NON NORMAL flag [true], DNIS [84717171], ANI [3125091111] with AGE (msecs) 22027 and Call History : 200919888|-1;84501003|1; [id:5004]

 

1570: 10.1.13.21: May 08 2021 18:28:18.003 -0500: %CVP_11_6_SIP-3-SIP_CALL_ERROR: CALLGUID = F1CeUJufR3xMaHQpVRTxnFdsmAa8EgdJ24D LEGID = F388AC07-7ACC11DA-8204A3FF-936FEC4D - [INBOUND]: Refer failed with 503 - Service Unavailable. May be a problem with Routing Configuration or Gateway Dial-Peer. [id:5004]


1573: 10.1.13.21: May 08 2021 18:28:18.003 -0500: %CVP_11_6_SIP-3-SIP_CALL_ERROR: CALLGUID = F1CeUJufR3xMaHQpVRTxnFdsmAa8EgdJ24D LEGID = F388AC07-7ACC11DA-8204A3FF-936FEC4D - [INBOUND] - ABNORMALLY ENDING - SIP code [38], Reason Hdr [Q.850;cause=38] Q850 Reason [38 - Network out of order, typically a TCL script abnormal disconnect.], GW call using SURV TCL flag [false], NON NORMAL flag [true], DNIS [84717171], ANI [3125091111] with AGE (msecs) 22058 and Call History : 200919888|-1;84501003|1; [id:5004]

Any one having any idea what could be the issue ?

 

Thanks,

Manish Raikwar

 

9 REPLIES 9

bill.king1
VIP Engager VIP Engager
VIP Engager

Do callers hear audio files (like menus, queue treatment, etc.)? Is it strictly a case where whenever the agent picks up the call (after having been in queue or not having been in queue) that the call drops?

Yes caller can hear the greeting, menu and able to insert the option (like press 1 or press 2), calls are also reaching to agent but as soon as agent pick the calls its dropped.

manish.raikwar1
Beginner
Beginner

Do you have any update on this ?

 

Thanks,

Manish Raikwar

Are you able to send calls to a label like for the agent and/or a label to the PSTN? If you're able to deliver calls to PSTN destination like a cell phone but not to agents, it may help you narrow it down as far as if something tied to UCM/gateway for instance.

Well i have tested 2 different scenarios  :

1. Removed the original script and create a script without any greetings and input, directly pointed to Skill group, at this point agents able to pick the calls.

 

2. Also i made direct calls from Finesse to PSTN number and it works fine.

 

I am not sure weather the issue could be with the Script or ECC variables or Microapp ? but i also think if the issue is with Script or ECC variables or Microapp, then calls should not be reach to agent 

 

Please advice

 

Thanks,

Manish Raikwar

Muhammed Ashiq
Beginner
Beginner

What version you are using.

 

Please check Agent target Rule configuration is applied.

Its 11.6 version, also its not related with ATR, i did checked the config.

Let me know if i need to check another thing in ATR.

 

Thanks,

Manish Raikwar

rikardkrvaric
Collaborator
Collaborator

I had a similar issue - not sure if this relates to you or not.

It was an issue with the codecs. We tested this with... 

 

Does it work with internal calls? We had no issue here. Internal calls could be received and placed.

 

Does it work with external calls? Here calls disconnected immediately when agent picked up.

So, the Gateway <--> UCCX/UCCE is no issue, but once the call is moved from UCCX/UCCE to Agent there was a voice codec mismatch, which caused the call to drop.

We were answering calls on IP Communicator and had the "Low Bandwidth" switch enabled in the CIPC Client...  (Same with Jabber on mobile)

Internal calls working fine when call is routing through CUCM RP, but when i am dialing throLeyugh CME gateway, calls are transferring to Agent but as soon as agent pick the call its dropped.

 

I am not using any special codecs here, i am using g711ulaw which is by default enabled.

 

Also i did try with Cisco Jabber, CIPC, Cisco 7961 and Cisco 7975 but no luck.

 

Let me know if i need to do additional configuration in SIP header invoice gateway ?

 

Can you please advice what should be the configuration ?

 

Thanks,

Manish Raikwar

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: