cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
11363
Views
20
Helpful
10
Replies
Highlighted
Beginner

Cannot log-in to Finesse Agent Desktop invalid ID/password UCCX

Hello,

I've been working with UCCX in a lab enviroment. When I try to log-in to https://UCCX_FQDN:8445 it shows "Invalid ID or password. Please try again". However, when I try to log-in to https://UCCX_FQDN:8445/cfadmin I am able to sing-in. I tried with some account and always get same result. I have my agents listed in resurces in UCCX. I also have them configured with a team and skills and group. In CUCM I assigned my users these roles: end-user, CTI enabled, and Allow control of all devices. One of my users is administrator and also is supervisor, with this one I am able to log-in to Finesse admin page, but not to Agent page.

Is there any configuration I am missing?

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

This is what happened: CUCM

This is what happened: CUCM v11 rejected AXL connections from CCX v10.X. So, I installed ciscouccx.106x.cucm11-compatible.14.cop.sgn and then I restart UCCX. After that, the agents were able to log-in to Finesse.

Thanks for all your help.

View solution in original post

10 REPLIES 10
Highlighted
Beginner

CCX version: 10.6

CCX version: 10.6

CUCM version: 11.0.1

Not using CAD, but Finnese Agent.

Highlighted
Cisco Employee

Please make sure that you

Please make sure that you have assigned the IPCC Extension at the End User level. Also, check if the phone is associated to the RmCm user or not. In case, agent is using Extension Mobility then assign that at the End User level as well as RmCm and make sure agent logs into EM first before trying to login into Finesse.

Also make sure that the agent phone is in Registered state. What phone model are you using there

Regards

Deepak

Highlighted
Beginner

Hi, thanks for your quickly

Hi, thanks for your quickly answer.

I already had IPCC Extension at the End User level. My agents` phones are associated to RmCm User in CUCM. I am not using EM for CCX matters. 

My phone models: 7945 and 7965. SIP phones.

Kind regards,

Heriberto.

Highlighted
Hall of Fame Master

Couple other things to

Couple other things to consider:

try unassociating and re-associating the phone with the rmcm user

Make sure the ACD extension you are logging onto is not shared between different devices

Make sure the "common device configuration" assigned to the phone is enabled for ipv4 only and not ipv6.

Make sure the ACD DN is set for max calls/busy trigger as 2/1

Highlighted
Beginner

Sometimes I've resolved some

Sometimes I've resolved some log-in issues by unasigning and re-associating the phone to RmCm user, and usually works. But now nothing happens. 

I checked the other points you wrote, and I am afraid I have those points rightly configured. Password for UCCX is taken from end-user configuration, isn't it? I think this problem goes before and DN or phone configuration. I've tried with local users and LDAP users having always the same result "Invalid ID or password. Please try again". 

Can be a certificate issue? Can be a problem with syncronization?

This question is out of this matter, but I have the doubt: Can route points created in CUCM be SIP instead of SCCP? It is possible to have a secure connection between CUCM and CCX (I mean, TLS and sRTP)? When I make a call to a trigger configured in CCX I see that the signaling is not encrypted and neither the media.

Regards,

Heriberto.

Highlighted
Hall of Fame Master

Correct, password comes from

Correct, password comes from end user in CUCM, if CUCM is integrated to LDAP it would be the LDAP password.

This is not a cert issue.

One thing to also check is the actual username is entered as it is defined in CUCM, meaning that if it has any upper case letters you enter it as such, for example if username is JSmith, you put the uppercase as you see them as unfortunately UCCX logins are case sensitive.

Highlighted
Beginner

With another client I have

With another client I had that issue. When I imported new users to CUCM via LDAP, they appeared in end-user config as "JSmith" and my CCX agents had to log-in with uppercase. In this case I see my users in lowercase, so it isn't the problem.

I don't know what else to check. Any logs o another configuration you can recommend me to see?

Kind regards.

Highlighted
Beginner

I found this:

I found this:

03737604: Jun 02 2016 13:07:05.994 -0500: [http-bio-8445-exec-5] INFO  com.cisco.ccbu.finesse.realms.ccrealm.CCRealmConfig - CCRealmConfig Authenticate userid : lolivo 
103737694: Jun 02 2016 13:07:06.084 -0500: [http-bio-8445-exec-5] ERROR com.cisco.ccbu.finesse.realms.ccrealm.CCRealmConfig -Unable to authenticate user lolivo 
com.cisco.uccx.finesse.exception.AXLServiceException: initCCMStub(): No Call Manager Active in the cluster
at com.cisco.uccx.finesse.axl.AXLClientSvc.initCCMStub(AXLClientSvc.java:132)
at com.cisco.uccx.finesse.axl.AXLClientSvc.<init>(AXLClientSvc.java:94)
at com.cisco.ccbu.finesse.realms.ccrealm.CCRealmConfig.authenticate(CCRealmConfig.java:129)
Any comments?
-Heriberto
Beginner

This is what happened: CUCM

This is what happened: CUCM v11 rejected AXL connections from CCX v10.X. So, I installed ciscouccx.106x.cucm11-compatible.14.cop.sgn and then I restart UCCX. After that, the agents were able to log-in to Finesse.

Thanks for all your help.

View solution in original post

Highlighted
Beginner

Thanks for posting .... this

Thanks for posting .... this fixed mine.  - didn't have much hair left : )

CreatePlease to create content