Showing results for 
Search instead for 
Did you mean: 
John Huthmaker

Cant set up backup in UCCX 8.5

I keep getting the error "Unable to access SFTP server or SFTP server too slow to respond." when I add our FTP server to UCCX.  I'm using the same server for Call Manager, Unity, and Presence and they all connect and back up just fine.  This is an SFTP server.  I have tested connecting over sftp with the same account I'm using for UCCX with both Filezilla and PSFTP and they connect fine.

Anybody know why UCCX is complaining?


Good to hear the issue was resolved.

The next thing I would have asked for was the logs to determine what the issue was.

I have the same problem.

I check my SFTP log and find what was wrong :

I didn't have compatible cipher in my SFTP server compatible with UCCX encryption.

I add aes256-cbc cipher in the SFTP server, and reload my SFTP service.

Disaster Recovery works fine now.

Thanks for the info Franck, after upgrading to OpenSSH 7.2 CCX DRS stopped working with the error:

CiscoDRFFailure: Reason: Unable to access SFTP server or SFTP server too slow to respond.

All other UC elements (CUCM, CUC, CER, CUPS) continued to work as expected.

The ciphers that CCX 8.5 supports can be found in the OpenSSH logs /var/log/auth.log

fatal: Unable to negotiate with x.x.x.x port xxxxx: no matching cipher found. Their offer: aes128-cbc,3des-cbc,blowfish-cbc,aes192-cbc,aes256-cbc,arcfour,arcfour128,arcfour256 [preauth]

To re-enable aes256-cbc you can add the below to the /etc/ssh/sshd_config file, restart the sshd service on your SFTP server and DRS will continue to work.

Ciphers +aes256-cbc

OpenSSH man page for sshd_config:

Ciphers specifies the ciphers allowed.  Multiple ciphers must be comma-separated.  If the specified value begins with a ‘+’ character, then the specified ciphers will be appended to the default set instead of replacing them.

The supported ciphers are:

3des-cbc, aes128-cbc, aes192-cbc, aes256-cbc, aes128-ctr, aes192-ctr, aes256-ctr,,, arcfour, arcfour128, arcfour256, blowfish-cbc, cast128-cbc,

The default is:,aes128-ctr,aes192-ctr,aes256-ctr,,

The list of available ciphers may also be obtained using the -Q option of ssh(1) with an argument of “cipher”.

Nishad Ismail

Hi Guys,

Even i am facing the same issue with UCCX ,When i configured the same SFTP server in CUCM am able to add the backup device ,when i trying UCCX getting the same error

I have tried multiple SFTP server,Still getting the same issue, the credentials are correct and the backup path too

Can you please suggest


Hi John,

Please share the following logs:

  • Cisco Unified CCX DRF
  • DRF Local
  • DRF Master

Which SFTP server are you using?

Thanks & Regards,
"Protocol, then product"

Thanks & Regards, Anirudh "Protocol, then product"

Command Line Interface is starting up, please wait ... /var/log/active/platform/log/cli.bin (Read-only file system)         at Method)         at         at         at         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)         at sun.reflect.NativeMethodAccessorImpl.invoke(         at sun.reflect.DelegatingMethodAccessorImpl.invoke(         at java.lang.reflect.Method.invoke(         at org.apache.log4j.config.PropertySetter.setProperty(         at org.apache.log4j.config.PropertySetter.setProperty(         at org.apache.log4j.xml.DOMConfigurator.setParameter(         at org.apache.log4j.xml.DOMConfigurator.parseAppender(         at org.apache.log4j.xml.DOMConfigurator.findAppenderByName(         at org.apache.log4j.xml.DOMConfigurator.findAppenderByReference(         at org.apache.log4j.xml.DOMConfigurator.parseChildrenOfLoggerElement(         at org.apache.log4j.xml.DOMConfigurator.parseRoot(         at org.apache.log4j.xml.DOMConfigurator.parse(         at org.apache.log4j.xml.DOMConfigurator.doConfigure(         at org.apache.log4j.xml.DOMConfigurator.doConfigure(         at org.apache.log4j.xml.DOMConfigurator.configure(         at sdMain.main( java.lang.NullPointerException         at         at         at         at org.apache.log4j.AppenderSkeleton.doAppend(         at org.apache.log4j.helpers.AppenderAttachableImpl.appendLoopOnAppenders(         at org.apache.log4j.Category.callAppenders(         at org.apache.log4j.Category.forcedLog(         at         at sdMain.main( log4j:ERROR No output stream or file set for the appender named [CLI_LOG].   Welcome to the Platform Command Line Interface     WARNING:         The /common file system is mounted read only.         Please use Recovery Disk to check the file system using fsck. admin:

--------------------------------------------------------------------------------------------------------------------------------------------Hitting Defect CSCti28336. 1. Reboot the server via CLI if you can, otherwise power-cycle the server by holding down the power button for 5 seconds or more. 2. Boot from a CUCM recovery disk and selection option f to perform a filesystem check. 3. reinstall and restore from backup may be the only way to recover completely.  Since you don’t have a backup then you will need to build from scratch. ---------------------------------------------------------------------------------------------------------------------------------------------- We have inserted the the recovery disk and selected option F ,performed the filesystem check Now we are able to create the Backup device and backup is successful :)

Hi Nishad,

You were bang on the spot! If you took a look at your CLI exception, you would see "Read only filesystem" mentioned.

Great to see that you fixed it yourself.

Thanks & Regards,
"Protocol, then product"

Thanks & Regards, Anirudh "Protocol, then product"
Nathan LeNevez

I had this problem with a Linux based SFTP server.


I had to add the following to /etc/ssh/sshd_config to get it to work with UCCX (it worked fine with CUCM):


PasswordAuthentication yes




Recognize Your Peers
Content for Community-Ad