Showing results for 
Search instead for 
Did you mean: 

Rising star

Cisco Finesse Silent Monitoring Issue



I am trying to setup silent monitoring on Cisco Finesse and getting following error message on Finesse Supervisor Desktop Client:


Unable to Silent Monitor at this time (CTIError=Invalid Authorization User Specified)

Does anyone know the root cause?




Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.
Everyone's tags (1)

You got the solution, I am

You got the solution, I am getting same error .


Any chance it's this? https:/

Any chance it's this?



Rising star

You don't say if this is UCCX

You don't say if this is UCCX or Enterprise

Make sure your jtapi user has "Standard CTI Allow Call Monitoring" set under permissions.

If this is UCCX then it should have set that permission when it created the jtapi user, Enterprise you will need to set it



Hello Graham, sorry to bug

Hello Graham, sorry to bug you with this old post but I am same difficulties. We have CCX Premium HA cluster and just getting ready to deploy Finesse. When you said ' Make sure your jtapi user has "Standard CTI Allow Call Monitoring" set under permissions...' you mean the agent should have this or the Supervisor? If it is Supervisor, I have this option configured. Thanks

Cisco Employee

Hi Graham, Please find below

Hi Graham,


Please find below all the information that you need to know about setting up Silent Monitoring on Finesse:

Configuration For Silent Monitoring:

++ Configure an test agent on UCCX with an unique IPCC Extension.
++ Make sure that the agent phone has the Built in Bridge (BIB) On. This can be done on the phone or at the Cluster level by setting the Default Parameter to On.
++ Login the agent to Finesse.
++ Make sure that the Supervisor is also logged into Finesse and is in the NOT READY state.
++ make sure that the Supervisor also has an unique IPCC Extension.
++ Ensure that the RMCM user has the required roles for Call Monitoring and Call Recording which is Standard CTI Allow Call Monitoring and Recording. Note: This is automatically done by CCX when adding the RMCM user on the CUCM. Just ensure the correct roles.
++ Assign the Monitoring CSS on the Supervisor Phone to contain the Partition of the agent line.
++ Once an agent is in the TALKING state, perform the Silent Monitoring.
++ Please ensure that the agent phone and Supervisor Phone are compatible for Finesse using the following compatibility matrix:

Section IP Phones for Cisco Finesse.


Considerations For Silent Monitoring:

++ The Supervisor Needs to login to Finesse and must be in NOT READY State.
++ The Agent needs to login to Finesse and must be on an active call – TALKING State
++ The Supervisor will have the Silent Monitoring Button Visible only when he selects an Agent in TALKING State.
++ The Finesse with UCCX uses the native Call Recording and Monitoring functionality of the Call manager.

++ Link for Configuration on Call manager:


++ Following is the guide for UCCX that talks about unsupported and supported configurations for agent phones:

++ The IPCC Extension needs to be unique and must not be shared across devices or line groups.

Troubleshoot:(After the above config is verified)


Step 1: Confirm if the Finesse Desktop client session is behaving fine

  • Is the “Silent Monitoring” button enabled for the Agent who is currently in TALKING state (who you want to Monitor)?
  • Upon clicking the “Silent Monitoring” button, is the request successfully coming to the Finesse Server? Confirm by tailing and checking Finesse desktop and webservices logs. If not, report issue to Finesse.

Step 2: Is the request to start Silent Monitoring coming to CCX Engine from Finesse Server?

  • Check from Finesse webservices logs that a CTI request SUPERVISE_CALL_REQ (with SupervisoryAction = 1) is being sent out
  • Also, enable ICD_CTI and SS_RM for CCX Engine and confirm that this request is received by CTI server and processed correctly. If things are fine so far, CCX RmCm will request CUCM to start Monitoring via JTAPI (startMonitor()).
  • If the JTAPI request is successful, CCX returns back a SUPERVISE_CALL_CONF. Else, a CONTROL_FAILURE_CONF is sent back with the following error codes and their reasons:

88046 – BIB not configured.
88048 – Monitoring Settings not configured
88056 – Monitoring Already in progress.







Thank you very much Deepak

Thank you very much Deepak for detailed instructions. I will try this out and let you know.


Re: Hi Graham, Please find below

Hey Deepak, 


This was a great write up that I followed completely and got it working almost 100%. There's a weird issue I'm seeing though which I'm wondering if you have any information on. 


The supervisor can Silent Monitor on an 8851 no problem but when I switch their IPCC Extension and RmCm controlled device to an IP Communicator they cannot hear anything, just dead air. 


Then I did something for an experiment that I know is wrong but wanted to see if it would work by adding the IPCC extension to the 8851 even though it wasn't the RmCm controlled device and if the Supervisor puts the Monitor on hold on the IP Communicator then retrieve it from the 8851 they can hear it just fine. 


Any thoughts on this issue? 





Re: Hi Graham, Please find below

Hi There,


Just moved to Finesse and I have the same issue, only dead air when monitoring the IP communicators. We are running version 10.6 on the CCX and version & on the IPC's


Any help, would be much appriciated.






did you ever get this

did you ever get this resolved? Can you share some information? I am having same problems.

Rising star



  • Make sure that an Access Control Group assigned to Supervisor doesn't have following role: Standard CTI Allow Reception of SRTP Key Material

  • The second common overlooked setting that will cause this error, is the Agent-Phone-Device must have the Built-In-Bridge enabled. This is required because the CallManager will silently bridge the Supervisors Phone to the Agents-Phone, so that the Supervisor can monitor the conversation between the Customer and the Agent. This is also found in the CallManager Admin Page>Device>Phone>Select the Agents Phone Device>Under the main “Device Information” page, check to ensure the Built In Bridge is either set to = Enabled, or if Default is chosen please ensure the global built in bridge setting is set to “Enabled”. To check this global setting, In CallManager Admin Page>System>System Parameters>Choose the Pub node>choose Cisco CallManager>Clusterwide Parameters section>look for Builtin Bridge

  • Third, you must confirm that the Supervisors-Phone-Directory Number, has the Calling Search Space which contains the Agent-Phone-Directory Number, assigned to the “Monitor Calling Search Space”. To check this navigate here in the CallManager Admin Page>Device>Phone>select the Supers Phone>Select the Supers ICD DN>scroll all the way down to here: The Monitoring Calling Search Space must be set to a CSS which contains the Agent ICD extensions.



Vaijanath Sonvane

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.

Re: Resolution:

Very Helpful.  Thank you.  

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards