Showing results for 
Search instead for 
Did you mean: 

CTIOS 8.5(2) Agent Desktop fails to start - file not found exception

Level 10
Level 10

I can run the CTIOS 8.0(1) Agent Desktop OK against my 8.5(2) system, but when I install 8.5(2) SR on the client machine (running XP SP3), the app will not start. (Actually trace shows it starts a little bit but debugging doesn't point out the problem).

It pops up a Windows Message wanting to send a report to Microsoft (yeah, we know where that goes) and I can see it say something about a file not found exception.

I uninstall CTIOS 8.5(2) and it works perfectly.

Makes you wonder how this passed QC testing. I have tried on two different machines.

Anyone have the workaround that establishes the file it's looking for?



22 Replies 22


   I had the same problem, I called TAC, I launched it and it worked?  And now I can't get it to break?  My client is having the same issue so tomorrow I am going to webex with TAC and one of their PC's and see what happens...



Here is the internal BugID they can't share any information with me about!

Dear valued Cisco Bug Toolkit customer, the bug ID  CSCto05094 you searched contains proprietary information that cannot be  disclosed at this time; therefore, we are unable to display the bug  details. Please note it is our policy to make all externally-facing bugs  available in Bug Toolkit to best assist our customers.  As a result,  the system administrators have been automatically alerted to the  problem.

Time to beat up the account team for some help!


Did you guys find a solution to this problem?  I have the exact same issue.  I do have a TAC case open and referred them to the BUG ID above.



I'm "happy" I'm not the only one who had this problem.



Glad to join the misery loves company thread - LOL .  I was able to get it to work with a newer (lets say 8.0.1a) installer I got from my partner(then 8.5.2 upgrade), but it only worked on one machine.  I thought I had the fix and tried 2 other supervisor machines but they did not work.  I'm tempted to try another "new" XP machine.  Could it be some old registry entries causing the issue?  The machines I am trying to upgrade have had versions 6.0, 7.0, 7.5 or some combination of these previously.


investigating. stay tuned.

I still have my TAC case open but I also have a workaround that seems to work.  As Chad described above he had a machine that the 8.5.2 upgrade originally did not launch on but then magically started working on.  I also came across that case. Once I had one working machine I could upgrade it and downgrade successfully without issues.   Seeing that the 8.5.2 installer examines the system to be upgraded I figured it's checking the registry and/or the installation files. I then did the following:

Working system

1) Downgrade working 8.5.2 system to 8.0.1

2) Export the Cisco Systems Inc key from this 8.0.1 system

3) Copy the CTIOS Client and CTIOS Silent Monitor directories for the 8.0.1 system

Non working System

4) Stop the CTIOS Silent Monitor system

5) Delete the Cisco System Inc key from the reg

6) Import the Cisco Systems Inc key from the working system

7) delete the existing CTIOS Client and CTIOS Silent Monitor directories

8) Copy in the CTIOS Client and CTIOS Silent Monitor directories from the working system

9) Run the 8.5.2 installer

Reboot - and run the agent/supervisor desktop

I did this on several test machines and it worked every time.  I have upgraded about 5-6 supervisors and they all say it's working fine as well.


Hi, if anyone is still looking for workaround from Cisco, refer to the steps for this bug ID: CSCts40635 - Error While launching CTIOS client,  System.IO.FileNotFoundException.

According to TAC engineer, this bug is fixed in ctios release 8.5(3) which is expected by mid November.