Showing results for 
Search instead for 
Did you mean: 

CU CCX call redirect not working

hi everybody hope one of you all can help me.



im trying to redirect a call to voicemail when all the agents are busy, i tried the attached script but this code doesnt worked. when i update it in the CCX the agents got unlogged and nothing happens tha call stills there no voicemail

as you can see in the attached file voicemail is the name of a variable with the "8000" (callmanager pilot number)


any help will be awesome


When you say it doesn't work, which branch of the step does it go to?

You're saying the agents are being logged out?

Why are you sending the call to the voicemail pilot?  Wouldn't you rather send them to a mailbox or a call handler?

What does the caller hear?

yes i update the script in the ccx and the only agent is being logged out.

somebody told me to send the call to "8000" (voicemail pilot) the caller only hears the queuePrompt

i just wanna send the call to a voicemail thats it.(queued Branch)



Do you mean to say the agent is going "Not Ready"  when they fail to answer the call?

If you debug the script,which branch of the Call Redirect step is being chosen?

this system is very disappointing !!!

yes they go to not ready when i update the script

if i perform a debug the call got stuck in cola servicio: connected and keep ringing forever but no agent got a phone ringing until i stop the debug.


It has to error out on a step, but you're saying it goes to the connected branch and keeps ringing but no agent gets the call?

It sounds like you have an agent that the system still thinks is logged in and ready.  Are you using Finesse?

It doesn't sound like it's even getting to the Call Redirect step.

not using finesse 

it keeps ringing until i stop the debug.



That would be the normal behavior.  What happens if you step to the next step in the debug?  I'm trying to figure out where in the script it errors out.  

excuse for beeing so noob im really ashamed but how can i pass to the next stap in the debug?

i tried pressing step over button but it began to jump to the beginning of the script

I don't have the editor in front of me, but I think step over is the correct button. You're doing a reactive debug right?  And you have to click step over to get it to go down through the script right?

totally helpless 


Take a look at the 'Getting Started with Scripts' guide for the version of UCCX you're running.  That should get you squared away with Reactive Debugging:



Recognize Your Peers
Content for Community-Ad