cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

AMA-CUCM Troubleshooting: Best Practices for Reading Trace Files

1477
Views
10
Helpful
5
Replies
Beginner

CUIC Call Custom Variable report

Hello,

      I have created a Call Custom Variable report that's working fine and gives me the info I need from the script.  However, my issue is it's showing me info for every call that hits the script, not just those that get to the step where my set enterprise call info step is.  Is there a way to filter the report so that I only see the data for the calls that hit the set enterprise call info step?  I've created the Call Custom Variables report using the Application name in the filter.  I suspect this is why I'm seeing every call instead of only what I want, but I've tried other ways with no luck.  How can I get it so I only see what I want? 

1 ACCEPTED SOLUTION

Accepted Solutions

Try setting the filtering on

Try setting the filtering on CustomVariable1 only - some reports only support one filter at a time and it's not always clear which.

What I've suggested will filter out lines with blanks in there - or at least it does on my system.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
5 REPLIES 5

Hi

Hi

In the filter screen for the report, set the custom variable number that you have used in the 'set enterprise call info' to _% to show only non-blanks, or the specific value you are interested in to see unique matches.

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Beginner

Hey Aaron,

Hey Aaron,

     Thanks for the reply.  So if I understand what you're saying, I scroll down toward the bottom of the filter page and in the Custom Variable 1 (@param13) section, because I'm using Call.PeripheralVariable1 in the Set Enterprise Call Info step,  I need to put in just an underscore and a percent sign, _%, just as you typed in your reply?  I've done that and left the Application Name in the filter so the report is generated against the right one.  Anyway, I've done this and the report doesn't change.  So I'm either not understanding what you've said to do, or have done something wrong.  Could you clarify a bit more for me?

Try setting the filtering on

Try setting the filtering on CustomVariable1 only - some reports only support one filter at a time and it's not always clear which.

What I've suggested will filter out lines with blanks in there - or at least it does on my system.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Highlighted
Beginner

Ah, I see what you're saying

Ah, I see what you're saying and it works like that for me too.  Thanks, Aaron!

No problem :-)

No problem :-)

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards