cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

CUIC - Cannot See Folder/Subcategory Contents of User's Folders as Super-Admin User

Matthew Martin
Contributor
Contributor

Hello All,

In CUIC I have noticed that 2 of our Report Users have Subcategories or Folders in which I am unable to see the contents of those folders, i.e. I cannot see the Reports saved in those folders, even as the Super Admin user.

If the User who created the folder logs in and right-clicks the folder and views the permissions, everything is checked for both Group and All users for write and execute.

Any idea what I'm missing here? You'd think as the Superuser you should be able to see everything...?

Thanks in Advance,
Matt

1 ACCEPTED SOLUTION

Accepted Solutions

I think I figured it out...

 

Went to: Security > User Permissions > Assigned User Permissions > Chose Reports from Dropdown list and navigated to one of the reports in the folder. On the right side I filtered for the Admin User and checked his checkbox, then back on the left side I clicked the "Set Permissions" button and added Write/Execute permissions for the Admin user. Now, I am able to see the reports within that folder.

 

Since the Admin user seems to already have write/execute permissions at the folder level (*I created the folder for this user as the Admin user), I assume you have to do this individually for every report in a given folder...?

 

Thanks,

Matt

View solution in original post

6 REPLIES 6

jim-j
Beginner
Beginner

Can you "Run as" the user and verify the permissions yourself?  Maybe the reports have different (unique) permissions from the folders?

senthilnatarajan
Enthusiast
Enthusiast

Matt,

 

I have seen this folder permission never worked as intended in any CUIC (UCCX or PCCE or UCCE). I have never seen the folder permission inherited. the way I always fix is by setting the individual permissions for the root account instead of applying it at the folder level.

 

 

HTH

Senthil

 

Sorry for the delay. Just getting back to this after the long weekend (*and the 2nd covid shot)...

 

Could you explain how I do this? I logged in as the User who own the reports in the folder. But, if you right-click any of the Reports, I'm not seeing any way to set permissions on individual Reports, which is probably not what you meant anyway...

Sorry, probably just not understanding what you mean?

 

Thanks Again,

Matt

I think I figured it out...

 

Went to: Security > User Permissions > Assigned User Permissions > Chose Reports from Dropdown list and navigated to one of the reports in the folder. On the right side I filtered for the Admin User and checked his checkbox, then back on the left side I clicked the "Set