cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
727
Views
0
Helpful
14
Replies
Highlighted
Enthusiast

Debug Call flow Project hanging

I am using Call Studio 10.5, and when I try to debug the following call flow project, my debug will will hanging after I select the option for the menu... I cannot figure out why this happen..

Here is the call flow I have:

Main.jpg

Log.jpg

I don't see anything that will be cause debugger hanging.. so I don't know how to resolve this

This issue only happen sometimes

14 REPLIES 14
Rising star

Re: Debug Call flow Project hanging

1) Has the Debugger ever worked for a simple application? I would try to

get it working for a super simple app (Start, Audio, CVP_Subdialog_Return).

2) When you say the Debugger 'hangs' - does that mean the CONNECT button

never becomes enabled (in the bottom right phone pad)?

You can look at the Debugger's logs - they are in these directories:

A)

C:\Cisco\CallStudio\eclipse\plugins\com.audiumcorp.studio.debug.runtime\AUDIUM_HOME\logs

- look at the GlobalErrorLogger if the Connect button won't become enabled.

B)

C:\Cisco\CallStudio\eclipse\plugins\com.audiumcorp.studio.debug.runtime\AUDIUM_HOME\applications\appname\logs

- look here if the app starts then stops.

3)There are a few other things that cause problems for the Debugger, but

try the above first.

Enthusiast

Re: Debug Call flow Project hanging

Like in the language_option, I type 1 in the panel, press enter. It should go to Application modifier named "Eng", then go to Main_Menu.

But it just hanging there, and the input form is freezing...

Rising star

Re: Debug Call flow Project hanging

It sounds like it's hitting a breakpoint.

Do you have a break point configured on any elements?

If you go to the upper-right box in the Debugger perspective, and click

on the tab named Breakpoints, you can see if you've mistakenly set a

break point somewhere.

Rising star

Re: Debug Call flow Project hanging

1.Look for break points.

2.Did you look at the logs that I suggested?

3. After you press 1 and Enter, if you look in the upper LEFT box in the

debugger, it'll show you the list of elements that have each executed

with the bottom-most one being the Start of Call, then SessionBegin

(above it), then InitData (above that).

Which element is it getting to?

4. You should go into the Window > Preferences > Call Studio Debug

Preferences window and select to have the Activity and Error logs

display in the debugger's console window. Then restart the Debugger. The

logs will display in the Bottom Left pane of the debugger. You might see

errors.

Enthusiast

Re: Debug Call flow Project hanging

Thanks, I will do it and keep track when the next time this issue happen

Enthusiast

Re: Debug Call flow Project hanging

It happens again...

Here is the screenshot

hanging.JPG

No error log come out... and it should give me the input field to enter the card number, but all the field are locked...

After waiting for 30 mins, I got "192.168.2.44.1498580067245.0.SkillGroupTest,06/27/2017 12:44:46.832,Card_Number_Enter,element,warning,A session has timed out after 30 minutes. This is most likely caused by a start of call class or action element at the top of the callflow not completing before the voice browser's fetch timeout occurred. To resolve it ensure this class executes in a timely manner or run it in the background. Session timeouts may also occur under high load or if there are issues with a load balancer or voice browser."

Also If I try to do the debug again after this without close the call studio, the console tell me server start up, but connect button is in grey. The only way I can do is close the call studio and open it up again

Rising star

Re: Debug Call flow Project hanging

Look in the Breakpoints tab - do you have a breakpoint set?

Or have you enabled Speech Reco or TTS under

Project/Properties/CallStudio/Debug ??

Perhaps the application is trying to execute some back end integration

at this point?

Why doesn't the logging at the bottom (Card_Number_Enter) ?match what I

see in the upper-left box (app is at the Lang_Option menu)?

Enthusiast

Re: Debug Call flow Project hanging

That is question I want to know too...

Also I realize the some symbol in the upper left is not correct also...


And no break point set

hanging.JPG


And I cannot find anything Debug setting in Call Studio 10.5, here is the screenshot for the choice under Properties\Call Studio


hanging.JPG

Rising star

Re: Debug Call flow Project hanging

Go to Window / Preferences / Call Studio / Debug and look there - be

sure speech reco is not selected.

Enthusiast

Re: Debug Call flow Project hanging

None of the voice are selected..

hanging.JPG

And I just realize another thing, since all the enter element is created by java class, if I switch the order for Card_Number_Enter and Language_Option menu, the Card_Number_Enter elements works fine, but Language_Option menu will hanging for me.. and I don't know why...

Rising star

Re: Debug Call flow Project hanging

These 2 things cause the Debugger to hang:

1. Are you setting fetchaudio URL at all???

*2. Is your program trying to play # in a TTS prompt? *

3. If you still can't figure anything out. Try to turn off log caching

for now - by going to project properties / Call Studio / General Settings.

Select the ActivityLog - and select edit, and edit again.

Scroll down and comment out the 3 lines having to do with caching:

Then test again with the debugger. This time the activity log stay up to

date with the application.

Beginner

Re: Debug Call flow Project hanging


@janinegraves wrote:

2) When you say the Debugger 'hangs' - does that mean the CONNECT button

never becomes enabled (in the bottom right phone pad)?

You can look at the Debugger's logs - they are in these directories:

 

A)

C:\Cisco\CallStudio\eclipse\plugins\com.audiumcorp.studio.debug.runtime\AUDIUM_HOME\logs

- look at the GlobalErrorLogger if the Connect button won't become enabled.

 



Hi Janine, we have faced the same problem, when CONNECT button never becomes enabled.

Actually it is enabled only for the first run, after that when I apply additional changes to the project, it will never get enabled. I have to restart the Studio to have it working. I'm using 12.0.1 version Studio.

By some reason GlobalErrorLogger logs are empy, they aren't even get created at all.

Did you have such experience?

Everyone's tags (1)
Enthusiast

Re: Debug Call flow Project hanging

Surprisingly, everything is good now...

All I did just start a new project, reuse my java code and test, working..

Come back to this project, also working now...

So weird behavior...

Enthusiast

Re: Debug Call flow Project hanging

This issue it happens again T.T

I already try to uninstall and re-install at least 5 times, but it stills randomly hanging on the debug...

I don't know how to trace the issue now.. but the flow works before....

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards