Showing results for 
Search instead for 
Did you mean: 

AMA-CUCM Troubleshooting: Best Practices for Reading Trace Files

Frequent Contributor

Empty wav file- CED not accepting digits

I’ve came across an old script where there is a wav file in front of the CED step however some reason the wav file has been recorded empty - don’t know why however my reason question is that the CED step failed to collect any digits and just loop round playing invalid entry. If I placed a recorded wav file it worked  correctly- was it because there was no prompt being played


i don’t know why there is a empty wav , which I’m going to delete later to tidy things up



VIP Advisor

Re: Empty wav file- CED not accepting digits

I can't picture what you're describing. Can you share a screenshot or something?

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
Frequent Contributor

Re: Empty wav file- CED not accepting digits

Yes, it’s weird , I’m out off the office


basically the script is


1. set pv10 “welcome.wav”

2.Run external script 

“welcome to x company “

then this is where the issue is

3.set pv10 “empty.wav” -this wav is recorded as blank-nothing has been recorded, perhaps it was configured as an “holding” place for future ad-hoc prompts 

4. Gd,-10 - plays the step in 3.


however the dtmf inputs are ignored


if I replace step 3. With a actual recorded wav then it works



Re: Empty wav file- CED not accepting digits

Like others have mentioned, it may be that the callers don't have a chance or know to press a prompt, so that's why it fails/repeats.

You might want to confirm what you mean when you say empty file. Is it 0kb, is it 5 seconds of silence, etc., as that would impact/help as well.

Is the idea for instance that this is some type of secret VIP/bypass where only people in the know would know to hit a key when they hear silence, is that the idea or something?


Re: Empty wav file- CED not accepting digits

Wav file has got nothing to do with the Caller entered digits, you need to understand why the digits are failing to get parsed through the system. You can also verify if microapp to get digits in network VRU node. also I'd suggest to add a DTMF validation node after CED to verify what digit user has pressed.  If nothing works out,  we need Gw log analysis for digit collection.


Re: Empty wav file- CED not accepting digits

The most logical reason might be that as callers heard nothing they pressed nothing. Have you tried calling in and pressing anything while the empty wav is playing?



CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards