cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1004
Views
0
Helpful
3
Replies

Error on Rest API make call request

I have problem with sending request to Cisco Finesse REST API. I have small application which in first step get all users (this request works fine), nest step is send request to make call for choosen agent and at this moment I have message error 500.
I have 2 Finesses - in one I don't have this problem.

I am look for Cisco FInesse logs and have lthis log:

[exception=org.apache.commons.io.input.XmlStreamReaderException: Invalid encoding, CT-MIME [Application/XML] CT-Enc [null] BOM [null] XML guess [null] XML prolog [null], Invalid MIME][log_message=Invalid encoding, CT-MIME [Application/XML] CT-Enc [null] BOM [null] XML guess [null] XML prolog [null], Invalid MIME]: XML Security Filter Error

The problem is with xml message: <Dialog><requestedAction>MAKE_CALL</requestedAction><fromAddress>extension</fromAddress><toAddress>destNew</toAddress></Dialog>

I try to use few encodings for example:

var bytes = Encoding.GetEncoding("iso-8859-1").GetBytes(PostData);

byte[] bytes = Encoding.ASCII.GetBytes(PostData);

1 ACCEPTED SOLUTION

Accepted Solutions

I fixed this problem
I had to add to content type encoding like:

ContentType = "Application/XML;charset=utf-8";

View solution in original post

3 REPLIES 3
dekwan
Cisco Employee

Hi Adrian,

HTTP status code 500 is an internal server error: https://developer.cisco.com/docs/finesse/#!dialogcreate-a-new-dialog-make-a-call/dialogcreate-a-new-dialog-make-a-call.

1. Are your agents logged in before you try to make the call?

2. Have you double checked that the phones are working?

3. Have you tried to manually make the REST API request via postman?

4. Take a look at the webservices log to see if the Finesse server received your request. I don't recognize that error that you have pasted.

Thanx,

Denise

Hi,

1. Yes, I make request get all agents to check agent state and if this state is not ready than call request to make call

2. Yes, I checked - I myself logging to FInesse and make some calls

3. Yes, via SOAP UI and this is working

4. This log is ffrom Finesse webServices logs.

I can add that we have Finesse 11.5 which is downgraded from 11.6, and Finesse 11.6. On this downgraded is not working, but on which isn't that works

Regards

I fixed this problem
I had to add to content type encoding like:

ContentType = "Application/XML;charset=utf-8";

View solution in original post

Content for Community-Ad