cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
713
Views
5
Helpful
21
Replies
e-pudge
Beginner

Finesse desktop chat - search doesnt work

I'm having an issue with Directory search within the chat window on the finesse agents. UCCX version 12.5.1. The desktop chat is almost working - I can change the status, and if I have a contact added as a favourite - they come up in the search. However, if I search for users in general - it just keeps coming back with Refine search message. This is a lab environment, so the number of users in the lab isnt huge. I've configured 3rd party ldap server and settings on my CUP server and within Jabber client directory search works fine.

In the finesse local log I'm just seeing this:

Dec 08 2020 17:17:02.389 +0000: CallControl : [ClientServices] [I] - [A2ACHAT - UserSearch] - ldapsearchresult event triggered : {"searchText":"inarra","outputResult":{},"hasExceeded":true,"isEnabled":true}
Dec 08 2020 17:17:03.566 +0000: CallControl : [ClientServices] [ ComponentsUtil ] - Setting focus on element having id chat-icon
 Dec 08 2020 17:17:03.568 +0000: CallControl : [ClientServices] [I] - [A2ACHAT - SearchListeners] - Publishing on OpenAjax Hub Topic:[ON_CHAT_SEARCH_CLEAR]

 

actual chat messages are also working fine.

Any ideas?

21 REPLIES 21
collinks2
Enthusiast

Hello,

If I can I understand you very well,you can can't search user@domain.com in the finesse desktop chat.

Did you start the directory service in the cup?

Check this link below:

https://www.cisco.com/c/en/us/support/docs/contact-center/finesse/214685-configure-finesse-12-0-agent-to-agent-ch.html#anc21

 

Yes the directory service is running and I can access any contacts saved as favourites (in jabber as the same user), but can’t search for any in the directory.

Just to be clear I am talking about the desktop chat box .

So on the document reference you sent- the last section basically is not working. I’ve setup the third party server and settings in CUP, when when I try to search for a user instead of seeing the directory list like in the screenshot in the article- I get a message Refine search. The users in the directory are LDAP users and not local CUP users

Yes,I know the users are LDAP users. I had this challenge with uccx 12.1. I
didnt enable the directory service in the cup. After I enabled it ,it
started working ..
You need to verify again the object search in the LDAP settings in the cup..
In the LDAP server, are the users in the "OU" or the "Users"?

The users are in an ou, so my base setting is configured as follows

ou=Demo Users, dc=domain,dc=net


Hi

collinks2
Enthusiast

Hello,

can you try this ?

User Object class = user,ou= Demo Users,dc= domain,dc= net

Make sure that imp setting in the uccx is using FQDN

Restart the directory service and xcp router in imp

The object class is specified in a different field, nevertheless, have tried it all on single line, also tried setting it to default cn=Users, but still the same result

Did you restart the directory service and xcp router?

Yep, multiple times
BalajiSivaraj49175
Participant

Configure AD configuration uses below optionsCapture2.JPG

BalajiSivaraj49175
Participant

Check sip trunk profile Capture3.JPG

BalajiSivaraj49175
Participant

Check the SIP trunk informationCapture4.JPG

Hi,

 

Just to be clear, my jabber setup outside of the UCCX finesse is working fine - including the directory search.

The LDAP settings are setup similarly to the screenshot you posted

 

The search in jabber does not depend on the LDAP setting in imp instead it
depends on the LDAP settings in the cucm.
I reinstalled my imp and configured the LDAP settings again and it is
working. I used "ou" instead of "cn". Each time you make changes in the
LDAP settings ,you must restart the directory service and xcp router.
Also ensure that login details to LDAP in the LDAP server settings are
correct.
Content for Community-Ad

Spotlight Awards 2021