cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
709
Views
5
Helpful
12
Replies
Hall of Fame Master

Finesse gadgets.Prefs issues

Finesse / UCCX 11.6(1) ES5.

When <UserPref> is configured in the XLM definitions, my gadget shows a settings button next to the title. However these settings never show up,looks like Finesse attempts to load an external source:

Mixed Content: The page at 'https://XXXX/desktop/container/#manageCustomer' was loaded over HTTPS, but requested an insecure script http://www.gmodules.com/ig/gadgetsettings?mid=8 <lots of private data follows>

This request has been blocked; the content must be served over HTTPS.

shindig.BaseIfrGadget.handleOpenUserPrefsDialog @ shindig-container:osapi:pubsub-2:loadingindicator.js?c=1&debug=1:6180

Clicking "Load unsafe scripts" in Chrome has no effect as it doesn't exist. Issues:

  1. The settings UI doesn't work.
  2. I was thinking that Finesse should never attempt to access any external resource?
  3. Is there a way to not show the 'settings' button at all? Perhaps another method to pass variables from XML to the actual script?

Now for another issue, apparently cosmetic only, there is another error that shows in Console:

<my sub FQDN>:8082/finesse/api/SystemInfo?nocache=1552765713234:1 Failed to load resource: net::ERR_SSL_PROTOCOL_ERROR

No surprise as 8082 is the HTTP port. Is this known or even better, corrected?

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: Finesse gadgets.Prefs issues

Hi,

 

Sorry, I didn't realize I forgot to give an update for this.

 

After talking to the Finesse team, they said that the UserPrefs in terms of having the user specify settings via the pop up prompt, is not implemented/supported. 

 

CSCvp01336 was opened due to the visibility of the "Settings" button/link which should be removed as part of the bug.

 

The ability to use UserPrefs as a way of setting key value pairs will still be available, which is what Finesse uses in the out of the box gadgets.

 

Thanx,

Denise

 

 

 

12 REPLIES 12
Cisco Employee

Re: Finesse gadgets.Prefs issues

Hi,

 

I will have to check on this after I get a hold of a 11.6 system. I don't remember ever seeing a settings button next to the title. Can you provide a screenshot? Also, which browser are you using?

 

It might be a day or two before I can get a system to check this out...

 

Thanx,

Denise

Hall of Fame Master

Re: Finesse gadgets.Prefs issues

Hi Denise, thank you for your reply.

Here's the button element inspection, as well the errors logged. As mentioned I'm using Chrome (latest 64-bits on Win).
The existence of a settings UI is summarily described in the Developer Guide.

The <UserPrefs> section defines controls that allow users to specify settings for the gadget. For example, a
personalized greeting gadget might provide a text field for users to specify their names. It describes the user
input fields that are turned into user interface controls when the gadget runs. User preferences are stored
persistently.

Settings.PNG

Cisco Employee

Re: Finesse gadgets.Prefs issues

Hi,

 

I was able to reproduce this issue on a 11.6 setup. I have reached out to the Finesse team to see if it is a bug.

 

Thanx,

Denise

Hall of Fame Master

Re: Finesse gadgets.Prefs issues

Thank you Denise.

What about the other issue - SSL on port 8082? Doesn't seem to cause any problem, but it would be nice to have an error free console.

Cisco Employee

Re: Finesse gadgets.Prefs issues

Hi,

 

When I removed the gadget with the <UserPrefs>, I didn't seem to see this error in my console. Do you see this error without the <UserPrefs> gadget?

 

Thanx,

Denise

Hall of Fame Master

Re: Finesse gadgets.Prefs issues

Yes. I've also tried a "dummy" gadget without init function, and still happens.

Hall of Fame Master

Re: Finesse gadgets.Prefs issues

Just to be clear. In the screenshot above, the "mixed content" error is related to a gadget using <UserPrefs>. If one remove that in the XML, the error goes away.

The "failed resource" error happens, at least for me, as long there is any 3rd party gadget configured in Team Resources.

Cisco Employee

Re: Finesse gadgets.Prefs issues

Hi,

 

I noticed in the first line of your original post that you said you were using UCCX 11.6(1) ES5. As far as I can see, UCCX 11.6(1) only has ES2. If you are on UCCE, Finesse has a 11.6(1) ES5. So I wanted to see if you are indeed on UCCX but on ES2 or using Finesse with UCCE and on ES5.

 

I have a testbed on UCCX 11.6(1) with no ES and using Chrome on a Mac (not Windows). I removed all of the gadgets and only added the LearningSampleGadget. I wasn't able to reproduce the error in the console.

 

So, I want to make sure I'm on the right build to see if the ES introduced an issue.

 

Thanx,

Denise

Hall of Fame Master

Re: Finesse gadgets.Prefs issues

Yes I'm running ES2

Active Master Version: 11.6.1.10000-51
Active Version Installed Software Options:
ciscouccx.11x.CSCvj74116-chrome67-ET.cop
ciscouccx.1161.ES02.24.cop
uccx-language-pack_26-11.5.1.10000-1.cop

The issue that I have is the first one described in my OP: UI settings doesn't appear and Finesse tries to load an external resource script.

The other one (SSL error) is of no concern to me and perhaps would be better to discuss it separately.

Cisco Employee

Re: Finesse gadgets.Prefs issues

Hi,

 

Thank you for the confirmation. I will upgrade my testbed to ES2 to see if I can reproduce the issue in order to see if the ES introduced this issue.

 

As far as the <UserPref> issue, the Finesse team was able to reproduce the issue in 11.6(1) and 12.0(1). They are currently investigating.

 

Thanx,

Denise

Cisco Employee

Re: Finesse gadgets.Prefs issues

Hi,

 

Sorry for the delay. I was having issues upgrading to ES2. Anyways, I finally did the upgrade and I couldn't reproduce the issue. Like I mentioned before, I used the learning sample gadget without any changes and couldn't see the same error you are seeing on my console.

 

Thanx,

Denise

Highlighted
Cisco Employee

Re: Finesse gadgets.Prefs issues

Hi,

 

Sorry, I didn't realize I forgot to give an update for this.

 

After talking to the Finesse team, they said that the UserPrefs in terms of having the user specify settings via the pop up prompt, is not implemented/supported. 

 

CSCvp01336 was opened due to the visibility of the "Settings" button/link which should be removed as part of the bug.

 

The ability to use UserPrefs as a way of setting key value pairs will still be available, which is what Finesse uses in the out of the box gadgets.

 

Thanx,

Denise

 

 

 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards