cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
974
Views
0
Helpful
9
Replies

Finesse non gadget sign-in not working

suun24
Beginner
Beginner

Finesse non-gadget sample working fine with Finesse v11.6 however, the same code doesn't work with Finesse v12.0.1.
getting below errors when signed-in (attached console log)
Errors are :
1) jquery-3.2.1.min.js:4 PUT http://localhost:70/finesse/api/User/Agent001 403 (Forbidden)

2) core-sys.js:801 Uncaught TypeError: Cannot read property 'status' of undefined
at _signInHandler (core-sys.js:801)
at Object.error (finessenongadget.js:59)
at i (jquery-3.2.1.min.js:2)
at Object.fireWith [as rejectWith] (jquery-3.2.1.min.js:2)
at A (jquery-3.2.1.min.js:4)
at XMLHttpRequest.<anonymous> (jquery-3.2.1.min.js:4)

 

 

Regards,


Sanmesh

9 Replies 9

dekwan
Cisco Employee
Cisco Employee

Hi,

 

The non gadget sample was tested against 12.0 so it should work. I haven't tested it out myself though.

 

Did you manually try to log into the 12.0 system with the same URI and credentials to see if it is successful?

Did you take a look at the Finesse webservices and realm logs to see why you are getting a 403?

 

Thanx,

Denise

Did you manually try to log into the 12.0 system with the same URI and credentials to see if it is successful?

- Yes. It works and gives the XML Response as Sign-out

Access this url: http://localhost:70/finesse/api/User/Agent001 and received an XML Reponse :

<User>
<dialogs>/finesse/api/User/Agent001/Dialogs</dialogs>
<extension/>
<firstName>Jane</firstName>
<lastName>Doe</lastName>
<loginId>Agent001</loginId>
<loginName>Agent001</loginName>
<mediaType>1</mediaType>
<pendingState/>
<reasonCode>
<category>LOGOUT</category>
<code>32766</code>
<forAll>true</forAll>
<id>28</id>
<label>Agent Initiated</label>
<systemCode>true</systemCode>
<uri>/finesse/api/ReasonCode/28</uri>
</reasonCode>
<reasonCodeId>28</reasonCodeId>
<roles>
<role>Agent</role>
<role>Supervisor</role>
</roles>
<settings>
<wrapUpOnIncoming/>
</settings>
<state>LOGOUT</state>
<stateChangeTime>2020-01-22T04:58:41.732Z</stateChangeTime>
<teamId>2</teamId>
<teamName>Team_IT_Tier1</teamName>
<teams>
<Team>
<id>2</id>
<name>Team_IT_Tier1</name>
<uri>/finesse/api/Team/2</uri>
</Team>
</teams>
<uri>/finesse/api/User/Agent001</uri>
<wrapUpTimer>-1</wrapUpTimer>
</User>

Did you take a look at the Finesse webservices and realm logs to see why you are getting a 403?

- Do we need to check these logs on Cisco Finesse Server?

jquery-3.2.1.min.js:4 PUT http://localhost:70/finesse/api/User/Agent001 403 (Forbidden)

 

is the error.

is this problem regarding jquery? Do i need to use latest jquery?

dekwan
Cisco Employee
Cisco Employee

The error that you pasted is from the client side. I am talking about the error from the server/realm side. Did you use the browser's debugger to confirm that the authentication is being sent? Is the authentication correct?

 

In your example of your trial, I believe you are doing a GET since you are getting a XML response back while the application is doing a PUT (per your logs).

 

Thanx,

Denise

server responded correctly when accessed directly via url.
Below is the error:
Request URL:
http://localhost:70/finesse/api/User/Agent001
Request Method:PUT
Remote Address:[::1]:70
Status Code:
403



description: Access to the specified resource has been forbidden.

dekwan
Cisco Employee
Cisco Employee

Hi,

 

There is something wrong from the client side. It is not giving you a 401, so the credentials are probably ok.

3.png

 

Did you look at the Finesse webservices and realm logs?

 

 

Thanx,

Denise

 

can you help us to find "Finesse webservices and realm logs" ?

Can we download these logs from RTMT by connecting Finesse Server?

Thanks,

Sanmesh

Please find Realm and web service logs attached.

Hi.

 

I think I saw in the DevNet support room that this issue is resolved. Can you confirm?

 

Thanx,

Denise

When I enabled_all (using CORS CLI command) for CORS then it started working but actually we want to add Origin and then it should work without enable_all. When we tired to add Origin using CLI command not able to add it is giving operation failed error.

We are using SANDBOX Lab 12.0.

 

Regards,

Pravin

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers