cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
638
Views
2
Helpful
5
Replies
Highlighted
Beginner

Gadgets fail after an upgrade from Finesse 9.0 to 10.5

Hi,

We upgraded from Finesse 9.0 to 10.5 in our lab environment and using the same old gadget files .xml and .jsp then copied them over to the new Finesse 10.5 box but unfortunately the gadget ceased to load up. Is there a compatibility issue with our existing xml and jsp files to the new version?

Regards,

Jayson J.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Did you update the xml for each of your gadgets? In each of them near the top you will probably see something to the effect of :

    <!-- jQuery 1.5 -->

    <script type="text/javascript" src="jquery-1.9.1.min.js"></script>

 

    <!-- Finesse Lib -->

    <script type="text/javascript" src="finesse-10.5.1.js"></script>

I am willing to bet when you check yours, you will see something along the lines of :

    <!-- jQuery 1.5 -->

    <script type="text/javascript" src="jquery-1.5*.js"></script>

 

    <!-- Finesse Lib -->

    <script type="text/javascript" src="finesse-9*js"></script>

Thats a problem and it is what is causing the break. get the files appropriate for your finesse version (in your 10.5 case it will be what you see in the top) and then edit your xml files to point at the appropriate JSs. Something to remember every time you upgrade (or down grade).

EDIT : and if you have an answer for my post How do I fetch a custom ECC within a 3rd party gadget? that would be swell!

View solution in original post

5 REPLIES 5
Highlighted
Beginner

Did you update the xml for each of your gadgets? In each of them near the top you will probably see something to the effect of :

    <!-- jQuery 1.5 -->

    <script type="text/javascript" src="jquery-1.9.1.min.js"></script>

 

    <!-- Finesse Lib -->

    <script type="text/javascript" src="finesse-10.5.1.js"></script>

I am willing to bet when you check yours, you will see something along the lines of :

    <!-- jQuery 1.5 -->

    <script type="text/javascript" src="jquery-1.5*.js"></script>

 

    <!-- Finesse Lib -->

    <script type="text/javascript" src="finesse-9*js"></script>

Thats a problem and it is what is causing the break. get the files appropriate for your finesse version (in your 10.5 case it will be what you see in the top) and then edit your xml files to point at the appropriate JSs. Something to remember every time you upgrade (or down grade).

EDIT : and if you have an answer for my post How do I fetch a custom ECC within a 3rd party gadget? that would be swell!

View solution in original post

Highlighted

Thanks Colin. I'll go test that out in our lab.

Highlighted

Did it work?

Highlighted

Sorry for the late reply since we're kinda busy these weekend. I have already updated the xml files to point to the latest javascript files which I got on this url Finesse but unfortunately the gadgets didn't popup. I am currently digging up logs for review.

Highlighted

One issue we've found is using an agnostic protocol.

For example, your Finesse servers are probably running on SSL, or HTTPS. The screen pop from an IFRAME might be calling HTTP. So, instead of calling the URL resource HTTP://myresource.com, just use //myresource.com

Content for Community-Ad