Showing results for 
Search instead for 
Did you mean: 

Icons Not appearing in CAD Toolbar - UCCX 9.0

James Carlson
Level 1
Level 1


Hello. I am running UCCX 9.0.2 and I am having an issue with my Icons not displaying in my CAD Toolbar for my Agents.

This is defined in the Desktop Work Flow Administrator at:

Work Flow Configuration => Work Flow Groups => Call Centre => CAD Agent => User Interface => Toolbar tab

The Agent's CAD appears like this:


As you can see, the icons do not appear but the buttons are active and do work.

I've tried adjusting the DPI and screen resolution to no avail.

Also, I've found that only the icons that come with the system will appear in the CAD toolbar. Any custom icons I try to add - regardless of pixel setting, or whether they are a .jpg, .gif, .png, etc. - does not work. I do not receive any error message and they will appear in the setup for the Toolbar in the Cisco Desktop Workflow Administrator, but they will not be visible in the CAD.

Are there specific guidelines/settings that are required by the CAD?

Any help is greatly appreciated.


5 Replies 5

Level 1
Level 1

Hi - I have the exact same problem... I've figured out it has something to do with permissions in the following folder:

C:\Program Files (x86)\Cisco\Desktop\Icons

The CAD agent writes a file to that folder if you have a custom icon setup.  It then removes it when you close the CAD.  

Though I don't know what it is exactly... some of my users get the icon no problem and some don't.  If I log in as a local admin, then the icon will appear.  I have not been able to figure out what exactly is the trick to making it work, but am sure it's permissions related.  If you were able to figure it out or have any suggestions please let me know.



Here are the requirements for custom icons that CAD needs:

■ ICO format

■ 50 Kb file size limit

■ 16 × 16 or 32 × 32 pixels

■ up to 256 colors


Note: CDA will allow you to set custom icons that do not meet this pre-req.



Christian Legg
Level 1
Level 1

I have found that this problem occurs when CAD is run on systems where the Windows Font Size has been changed from the standard 100%.

As an example, on my 13" laptop I normally run Windows Font Scaling on Win 7 at "Medium", which is 125%.  When I do this, the custom icons do not work.

If I set it to 100%, the font size drops and I have to squint, but the custom icons work OK.

I have also confirmed this on our call centre floor.  The two users who have their font sizes set to larger than 100% don't see the custom icons - but everyone else does.

I've tried 16*16 icons, 32*32 icons, both at 1, 2 and 4 bit colour depths and they just don't scale.

So it looks like CAD just doesn't display custom icons if your screen size/font scaling is anything other than 100%.

Here is the defect ID for the issue mentioned if you missed it Christian:




Thanks for that Arundeep - that at least confirms the issue.

Of course, if "small" is too small, and "large" is too large, then "medium" is all that is left for icon size selection and CAD breaks.

Still, I may be able to get the users to "go large".

thanks again