Showing results for 
Search instead for 
Did you mean: 

Community Helping Community


IPCC - One node in Partial Service

We have an IPCCX HA system where one server is in partial service, but all CTI ports  are correctly registered and are working, except for one.(RP 3008)

The logs show a problem with CTI RPs being out of service.

Additionally,I am using Cisco Contact Center Express  7.0(1)SR05_Build504   This contact Center is integrated with CUCM

As soon as I restart the server (IPCC), the problem is solved and it looks like nothing is wrong

Why did it failed ,Any idea?

Thanks for your help.

Logs attached .

Cisco Employee

Re: IPCC - One node in Partial Service


     One issue I see right off the bat is that your CUCM version isn't on the UCCX compatibility matrix for your release.  I've attached a copy below for your reference.  It is often seen in these cases that there are little "annoyances" that just come and go until you are on a fully supported release.  I would schedule an upgrade for your CUCM to get to which will be compatible.  From looking at the logs, I believe your root cause is the JTAPI versions just not meshing.  If you upgrade, this will resolve.

     One other item you could check is to be sure that the NIC that is actually the primary NIC on UCCX has it's binding order first.  To see this, open the network section, select "Advanced" and look at the bindings order.  Also, verify things like speed/duplex, host files, etc.  Finally, you may try to run a Data Check from the CM Telephony section of UCCX and see if that identifies any issues.  Have this fix any issues found and see if that helps.  I hope this can point you in the right direction, let me know if you need further assistance.


Re: IPCC - One node in Partial Service

Hi Robert,

I made a mistake about the IPCC version, originally the version was, however on January I did an upgrade to version, this last version does appear on the compatibilty matrix.

I also have done all the test you advice. Another thing I noticed is that when the problem happens, in the IPCC-1 (normally the primary node) some services appear as Master and others as Slave, and at IPCC-2 occurs something similar, some services appear as Master and others as Slave.

Is there anything else I should be looking for?

Cisco Employee

Re: IPCC - One node in Partial Service

It's very hard to tell after you fixed it. If you have the logs when RP went out of service, it will help. A few suggestions.

1. Set your tracing level to default. It burdens the engine with lots of debugs turned on.

2. If you have DB subsystem in use, make sure all of the DSNs are working.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here